C#项目”XXXXX”针对的是”.NETFramework,Version=v4.7.1”但此计算机没有安装它 等等问题

我在公司遇到这样一个问题:C#项目”XXXXX”针对的是”.NETFramework,Version=v4.7.1”但此计算机没有安装它

就是我在打开别人的项目,发现别人的项目.Net Framework的版本 高于我电脑的版本(准确的说是“高于我开发环境.Net Framework的版本”)。

可以选择降低版本(选第一个):

不推荐,a: 因为别人版本高,你的版本低,不同步,万一你们代码合并呢?svn呢,git呢?

不推荐,b:我还不如更新自己的电脑环境,一次解决,不用再愁着问题,反正我也成是高版本了(向下兼容)

所以我选着了“下载.NetFramework,Version=v4.71的目标包”,在浏览器下载,要么浏览器打不开这个链接,要么就是打开了链接,下载下来安装失败(失败原因是我电脑已经有高于或者已经有该版本的.Net Framework了)

这就纳闷了,既然我电脑有“已经有高于或者已经有该版本的.Net Framework了”,那为什么还是打不开别人高版本的项目。

后来经过折腾明白:Windows 8或10系统,自带有.Net Framework 较高的版本,也就是你电脑自带可以运行任何托管在.Net Framework的项目。

而你自己VS开发环境,也有自己独立开发的.Net Framework 的版本,可以理解为二个环境,我也不明白为什么还要搞二个?可能开发环境的比较高级吧,里面有很多的监控和调试吧?

所以我下载下来的东西是Windows 8或10系统 里面的.Net Framework ,所以安装会报错“已经有高于或者已经有该版本的.Net Framework了”,那么解决思路,是下载VS开发环境 的.Net Framework 的版本。

方案一:

下载路径为:

https://www.microsoft.com/net/download/visual-studio-sdks

参考如下,下载你要对应的开发版本(Developer Pack):

下载完毕,即可安装,完美解决。

 

 

方案二:

打开VS的修复工具(就是系统菜单和VS启动挨在一起的),更改.Net Framework开发版本环境。(我只在VS2017找到这个修复工具,VS2015我没找到,大家如果找的到的话,欢迎留言)

VS2017那个配置工具程序吧?

 

以上参考启示来自 https://www.cnblogs.com/netxiaohui/p/5744396.html 

posted @ 2018-04-07 21:12  CaptainBruke  阅读(...)  评论(...编辑  收藏