2017ICPC北京 J:Pangu and Stones

#1636 : Pangu and Stones

时间限制:1000ms
单点时限:1000ms
内存限制:256MB

描述

In Chinese mythology, Pangu is the first living being and the creator of the sky and the earth. He woke up from an egg and split the egg into two parts: the sky and the earth.

At the beginning, there was no mountain on the earth, only stones all over the land.

There were N piles of stones, numbered from 1 to N. Pangu wanted to merge all of them into one pile to build a great mountain. If the sum of stones of some piles was S, Pangu would need S seconds to pile them into one pile, and there would be S stones in the new pile.

Unfortunately, every time Pangu could only merge successive piles into one pile. And the number of piles he merged shouldn't be less than L or greater than R.

Pangu wanted to finish this as soon as possible.

Can you help him? If there was no solution, you should answer '0'.

输入

There are multiple test cases.

The first line of each case contains three integers N,L,R as above mentioned (2<=N<=100,2<=L<=R<=N).

The second line of each case contains N integers a1,a2 …aN (1<= ai  <=1000,i= 1…N ), indicating the number of stones of  pile 1, pile 2 …pile N.

The number of test cases is less than 110 and there are at most 5 test cases in which N >= 50.

输出

For each test case, you should output the minimum time(in seconds) Pangu had to take . If it was impossible for Pangu to do his job, you should output  0.

样例输入
3 2 2
1 2 3
3 2 3
1 2 3
4 3 3
1 2 3 4
样例输出
9
6
0
区间dp,当时我想的做法都是TLE的
我这个好像不太好,多了一层复杂度
#include<bits/stdc++.h>
using namespace std;
const int N=105;
int a[N],dp[N][N][N],n,l,r;
int main()
{
    while(~scanf("%d%d%d",&n,&l,&r))
    {
        memset(dp,-1,sizeof dp);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",a+i);
            dp[i][i][1]=0;
            a[i]+=a[i-1];
        }
        for(int z=2; z<=n; z++)
            for(int i=1; i<=n; i++)
            {
                int j=i+z-1;
                for(int k=2; k<=r; k++)
                    for(int t=i; t<j; t++)
                    {
                        if(dp[i][t][k-1]==-1||dp[t+1][j][1]==-1)continue;
                        int f=dp[i][t][k-1]+dp[t+1][j][1];
                        if(dp[i][j][k]==-1||dp[i][j][k]>f)dp[i][j][k]=f;
                        if(k>=l&&k<=r&&(dp[i][j][1]==-1||dp[i][j][1]>dp[i][j][k]+a[j]-a[i-1]))
                            dp[i][j][1]=dp[i][j][k]+a[j]-a[i-1];
                    }
            }
        if(dp[1][n][1]==-1)printf("%d\n",0);
        else printf("%d\n",dp[1][n][1]);
    }
    return 0;
}

 

posted @ 2018-01-01 14:41  暴力都不会的蒟蒻  阅读(567)  评论(0编辑  收藏  举报