PAT 1142 Maximal Clique[难]

1142 Maximal Clique (25 分)

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

 题目大意:clique是一个点集,在一个无向图中,这个点集中任意两个不同的点之间都是相连的。maximal clique是一个clique,这个clique不可以再加入任何一个新的结点构成新的clique。

输入是有n条边,给出每条边的两端节点,并且后面给出m个查询,查询是点集。

 //这个题目大意看了好几遍没看懂,这个clique也不是环,比如对第三个查询2 3,输出Yes,说明不是环了。

//思考了一下发现不太会,怎么去确定这个是maximal的呢?怎么去扩展判断呢?不会。

代码转自:https://www.liuchuo.net/archives/4614

#include <iostream>
#include <vector>
#include<cstdio>
using namespace std;
int e[210][210];
int main() {
    int nv, ne, m, ta, tb, k;
    scanf("%d %d", &nv, &ne);
    for (int i = 0; i < ne; i++) {
        scanf("%d %d", &ta, &tb);
        e[ta][tb] = e[tb][ta] = 1;//存储到邻接矩阵中,有边是1.
    }
    scanf("%d", &m);
    for (int i = 0; i < m; i++) {
        scanf("%d", &k);
        vector<int> v(k);
        int hash[210] = {0}, isclique = 1, isMaximal = 1;
        for (int j = 0; j < k; j++) {
            scanf("%d", &v[j]);
            hash[v[j]] = 1;//使用hash数组存储
        }
        for (int j = 0; j < k; j++) {//这里判断是否是一个click
            if (isclique == 0) break;//跳出两层循环
            for (int l = j + 1; l < k; l++) {
                if (e[v[j]][v[l]] == 0) {
                    isclique = 0;
                    printf("Not a Clique\n");
                    break;
                }
            }
        }
        if (isclique == 0) continue;//不进行下面的操作。
        for (int j = 1; j <= nv; j++) {
            if (hash[j] == 0) {//挨个判断其他所有的点,判断每一个点。
                for (int l = 0; l < k; l++) {//和当前检测中所有的点进行判断。
                    if (e[v[l]][j] == 0) break;//如果这个点不是的话,接着判断其他点
                    if (l == k - 1) isMaximal = 0;
                }
            }
            if (isMaximal == 0) {
                printf("Not Maximal\n");
                break;
            }
        }
        if (isMaximal == 1) printf("Yes\n");
    }
    return 0;
}

 

//柳神真厉害。

1.使用邻接矩阵存储图,右边标记为1.

2.对于输入的使用hash数组来标记,向量来存储

3.对图中所有剩下的点一一与当前检测中的进行判断。

 //学习了!

posted @ 2018-11-19 16:41  lypbendlf  阅读(176)  评论(0编辑  收藏  举报