PAT 1075 PAT Judge[比较]

1075 PAT Judge (25 分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (104​​), the total number of users, K (5), the total number of problems, and M (105​​), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either 1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

 题目大意:输入包括n个学生,编号从00001到N,包括K个题目,m次提交,对它们进行排序:

1.一个学生多次对一个题目提交,要取分数最高的一次;

2.如果一个学生没有提交过,或者是提交了均未通过编译,也就是输入未-1,那么不计入统计中,注意:这里提交了得分为0,和-1是不一样的,前者是通过了编译但是得分为0,后者是未通过编译。

我的AC:

#include <iostream>
#include <vector>
#include <cstdio>
#include <algorithm>
using namespace std;

struct Stu{
    int id,total,perfect,pass;//pass记录通过编译的题目数,如果为0,那么不进入list。
    int task[6];//先存上5道题的数组。
    Stu(){
        fill(task,task+6,-1);
        total=0;perfect=0;pass=0;
    }
}stu[100000];
int score[6];
vector<Stu> vt;
bool cmp(Stu&a,Stu&b){
    if(a.total>b.total)return true;
    else if(a.total==b.total&&a.perfect>b.perfect)return true;
    else if(a.total==b.total&&a.perfect==b.perfect) return a.id<b.id;
    return false;
}
int main() {
    int n,k,m;
    cin>>n>>k>>m;
    for(int i=1;i<=k;i++){
        cin>>score[i];
    }
    int id,tid,sco;
    for(int i=0;i<m;i++){
        cin>>id>>tid>>sco;
        if(sco!=-1)stu[id].pass+=1;//此处只要!=0就可以计入排序。
        if(sco==-1)sco=0;
        stu[id].task[tid]=max(sco,stu[id].task[tid]);//分数每次都取最高的那个。
        stu[id].id=id;
        //提交多次的要取得分最高的那次。
//        if(sco!=-1)
//            stu[id].total+=sco;
//        if(sco==score[tid])//AC数目也不能在这里判断,有可能会多次AC
//            stu[id].perfect+=1;//记录AC的题目数。
    }
    for(int i=1;i<=n;i++){
        for(int j=1;j<=k;j++){
            if(stu[i].task[j]!=-1)
                stu[i].total+=stu[i].task[j];
            if(stu[i].task[j]==score[j])
                stu[i].perfect+=1;
        }
        if(stu[i].pass!=0){
            vt.push_back(stu[i]);
        }
    }
    sort(vt.begin(),vt.end(),cmp);
    int rank=1;
    printf("1 %05d %d",vt[0].id,vt[0].total);
    for(int i=1;i<=k;i++){
        if(vt[0].task[i]==-1)
           printf(" -");
        else
            printf(" %d",vt[0].task[i]);
    }
    printf("\n");
    for(int i=1;i<vt.size();i++){
        if(vt[i].total!=vt[i-1].total){
            rank=i+1;
        }
        printf("%d %05d %d",rank,vt[i].id,vt[i].total);
        for(int j=1;j<=k;j++){
            if(vt[i].task[j]==-1)
                printf(" -");
            else
                printf(" %d",vt[i].task[j]);
        }
        printf("\n");
    }
    return 0;
}

 

//总体来说就是根据题目的要求来写,整个过程思路清晰的话,还是比较简单的。

posted @ 2018-11-18 15:33  lypbendlf  阅读(200)  评论(0编辑  收藏  举报