HDU——1213How Many Tables(并查集按秩合并)

 

J - How Many Tables
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 
 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases. 
 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 
 

Sample Input

2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output

2 4

 

 


会了并查集这题就很简单,按集合元素大小合并即可。

代码:

#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<sstream>
#include<cstring>
#include<cstdio>
#include<string>
#include<deque>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>
#define INF 0x3f3f3f3f
#define MM(x) memset(x,0,sizeof(x))
using namespace std;
typedef long long LL;
const int N=1010;
int pre[N];
int ran[N];
void init()
{
	for (int i=0; i<N; i++)
	{
		pre[i]=i;
		ran[i]=1;
	}
}
int find(int n)
{
	if(n!=pre[n])
		return pre[n]=find(pre[n]);
	return pre[n];
}
inline void joint(int a,int b)
{
	int fa=find(a),fb=find(b);
	if(fa!=fb)
	{
		if(ran[fa]>ran[fb])
		{
			pre[fb]=fa;
			ran[fa]+=ran[fb];
			ran[fb]=0;
		}
		else
		{
			pre[fa]=fb;
			ran[fb]+=ran[fa];
			ran[fa]=0;
		}
	}
}
int main(void)
{
	int tcase,i,j,x,y,n,m;
	scanf("%d",&tcase);
	while (tcase--)
	{
		init();
		scanf("%d%d",&n,&m);
		for (i=0; i<m; i++)
		{
			scanf("%d%d",&x,&y);
			joint(x,y);
		}
		int ans=0;
		for (i=1; i<=n; i++)
		{
			if(ran[i]!=0)
				ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}
posted @ 2016-05-21 09:46  Blackops  阅读(146)  评论(0编辑  收藏  举报