刷题总结——Collecting Bugs(poj2096)

题目:

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

题解:

  期望dp入门题,详见http://blog.csdn.net/xingyeyongheng/article/details/25179481

  主要是那个倒推的思想在期望dp中用得很多

代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cctype>
#include<ctime>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1005;
int n,s;
double f[N][N];
int main(){
    //freopen("a.in","r",stdin);
    while(scanf("%d%d",&n,&s)!=EOF){
        memset(f,0,sizeof(f));
        for(int i=n;i>=0;i--)
            for(int j=s;j>=0;j--){
                if(i==n&&j==s)    continue;
                double p1=(n-i)*(s-j)*1.0/(n*s)*1.0;
                double p2=i*(s-j)*1.0/(n*s)*1.0;
                double p3=(n-i)*j*1.0/(n*s)*1.0;
                double p4=i*j*1.0/(n*s)*1.0;
                f[i][j]=(f[i+1][j+1]*p1+f[i][j+1]*p2+f[i+1][j]*p3+1)/(1-p4);
            }
        printf("%0.4f",f[0][0]);
    }
    return 0;
}

 

posted @ 2017-11-01 14:17  AseanA  阅读(188)  评论(0编辑  收藏  举报