Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

"How am I ever going to solve this problem?" said the pilot. 

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number? 


Your program has to be efficient! 

Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.

Output

output one integer for each input case ,representing the largest number of points that all lie on one line.

Sample Input

5
1 1
2 2
3 3
9 10
10 11
0

Sample Output

3

看注释
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <algorithm>
using namespace std;
struct node
{
    int x,y;
}a[705];
int main()
{
    int n,i,ans,j,f,m;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
        }
        ans=2;
        for(i=1;i<=n;i++)
        {
            for(j=i+1;j<=n;j++)
            {
                //选择两点连成直线
                f=2;
                for(m=j+1;m<=n;m++)//节约时间,避免重复验证
                {
                    if((a[m].x-a[i].x)*(a[m].y-a[j].y)==(a[m].x-a[j].x)*(a[m].y-a[i].y))
                            f++;
                }
                if(f>ans)
                    ans=f;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}