快速简单的了解VLAN(VXLAN)和端口链路类型


我的微信公众号:启鱼RS

前言

本文介绍vlan、vxlan、接口类型的简单作用

一、VLAN是什么?

VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"

image

字段 长度 含义 取值
Type 2 Bytes 表示数据帧的类型 取值为0x8100时表示802.1Q Tag帧
PRI 3 bits 表示数据帧的优先级 值越大优先级越高(Qos)
CFI 1 bit 表示是否以标准格式进行封装 0表示MAC地址以标准格式进行封装,为1表示以非标准格式封装 ,以太网的CFI值为0
VID 12 bits 表示数据帧所属的编号 一共有2^12=4096种可能(0-4095)0和4095保留

1.优点

  1. 分割广播域
  2. 安全性
  3. 灵活性

2.为什么推出VXLAN

  1. 因为原本的4096的数量,无法满足服务器的虚拟化
  2. 虚拟机迁移

二、VXLAN又是什么?

VxLAN(Virtual eXtensible Local Area Network)的中文名为"虚拟扩展局域网"
image

字段 长度 描述
VXLAN Flags 16 bits 标记位
Group ID 16 bits 用户组ID,当VXLAN Flags字段第一位取1时,该字段的值为Group ID。取0时,该字段的值为全0
VNI 24 bits VXLAN网络标识,用于区分VXLAN段,由24比特组成,支持多达16M的租户。一个租户可以有一个或多个VNI,不同VNI的租户之间不能直接进行二层相互通信
Reserved 8 bits 保留未用,由8比特组成,设置为0

1.优点

  1. vlan有的它也有
  2. 网络标识数量的增加
  3. 构建大二层网络

三、创建VLAN

进入全局模式

<Huawei>system-view			//进入全局模式
[Huawei]sysname SW1			//修改设备名称
[SW1]

创建vlan(两种方法)

  1. 创建单个vlan
[SW1]vlan 10				//创建vlan 10
[SW1-vlan10]quit
[SW1]vlan 20				//创建vlan 20
[SW1-vlan20]quit
[SW1]
[SW1]display vlan			//查看创建的vlan
The total number of vlans is : 3
--------------------------------------------------------------------------------
U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
MP: Vlan-mapping;               ST: Vlan-stacking;
#: ProtocolTransparent-vlan;    *: Management-vlan;
--------------------------------------------------------------------------------

VID  Type    Ports                                                          
--------------------------------------------------------------------------------
1    common  UT:GE0/0/1(U)      GE0/0/2(U)      GE0/0/3(D)      GE0/0/4(D)      
                GE0/0/5(D)      GE0/0/6(D)      GE0/0/7(D)      GE0/0/8(D)      
                GE0/0/9(D)      GE0/0/10(D)     GE0/0/11(D)     GE0/0/12(D)     
                GE0/0/13(D)     GE0/0/14(D)     GE0/0/15(D)     GE0/0/16(D)     
                GE0/0/17(D)     GE0/0/18(D)     GE0/0/19(D)     GE0/0/20(D)     
                GE0/0/21(D)     GE0/0/22(D)     GE0/0/23(D)     GE0/0/24(D)     

10   common  
20   common  

VID  Status  Property      MAC-LRN Statistics Description      
--------------------------------------------------------------------------------

1    enable  default       enable  disable    VLAN 0001                         
10   enable  default       enable  disable    VLAN 0010                         
20   enable  default       enable  disable    VLAN 0020                         
[SW1]
  1. 创建多个vlan(或者连续的)
[SW1]vlan batch 30 40 50			//创建30、40、50
[SW1]vlan batch 10 to 20			//创建10到20的vlan(连续的)

四、介绍端口链路类型

一共有三种类型

  1. Access
  2. Trunk
  3. Hybrid

华为交换机默认的类型是Hybrid
image
思科的默认是Access

五、Access

基本配置

[SW1]interface GigabitEthernet 0/0/1			  //进入接口
[SW1-GigabitEthernet0/0/1]port link-type access   	  //配置为access模式
[SW1-GigabitEthernet0/0/1]port default vlan 10		  //把接口加入vlan 10
[SW1-GigabitEthernet0/0/1]quit				  //退出接口模式
[SW1]

在说特性之前,测试一下大家。下面的两个PC机可以互通吗,为什么呢?
image

答案是:可以

image

1.特性

  1. 接收方向:接收到一个不带标签(PVID)的数据,打上自己端口的标签(PVID)
  2. 发送发现:剥离掉和端口相同的标签,进行转发

PC机发送的是不带标签的数据

讲解为什么可以ping通

  • PC1发上去的数据是没有PVID的,SW1收到之后就给它打上Vlan10的标签
  • SW1在通过ARP知道了PC2的位置,然后从g0/0/1发送出去,g0/0/1的PVID和数据的标签相同,然后就剥离出来再转发给SW2
  • SW2就收到了一个没有标签的数据,打上了自己端口的PVID(Vlan20)
  • 发送给PC2时,PVID和端口的相同,剥离出来后再发送

六、Trunk

基本配置

[SW1]interface GigabitEthernet 0/0/2					//进入接口
[SW1-GigabitEthernet0/0/2]port link-type trunk 				//配置为Trunk
[SW1-GigabitEthernet0/0/2]port trunk pvid vlan 10			//设置本征vlan
[SW1-GigabitEthernet0/0/2]port trunk allow-pass vlan all 		//放行全部vlan(不一定要放行全部,可以限制某些vlan)
[SW1-GigabitEthernet0/0/2]quit						//退出接口模式
[SW1]

1.特性

  1. 接收方向:
    ①如果是带标签的数据,查看是否允许通过
    ②如果是不带标签的数据,打上自己端口的PVID,然后查看是否允许通过
    允许就接收,不允许就丢弃
  2. 发送方向:查看是否允许转发;
    ①如果允许转发,将数据里面的PVID和自己端口的PVID进行对比,一样就剥离转发;不一样就带标签转发

七、Hybrid

基本配置

[SW1]interface GigabitEthernet 0/0/1							//进入接口
[SW1-GigabitEthernet0/0/1]port link-type hybrid 					//配置为Hybrid
[SW1-GigabitEthernet0/0/1]port hybrid pvid vlan 10					//配置本征VLAN
[SW1-GigabitEthernet0/0/1]port hybrid tagged vlan 20					//允许vlan 20带标签转发
[SW1-GigabitEthernet0/0/1]port hybrid untagged vlan 30 					//vlan 30剥离标签后再转发
[SW1-GigabitEthernet0/0/1]quit
[SW1]

1.特性

  1. 接收方向:
    ①如果是带标签的数据,查看是否允许通过
    ②如果是不带标签的数据,打上自己端口的PVID,然后查看是否允许通过
    允许就接收,不允许就丢弃
  2. 发送方向:查看是否允许转发;有就可以允许转发,此时查看端口动作
    ①Tagged 带标签转发
    ②Untagged 不带标签转发

Hybrid和Trunk的差别就是Trunk只能剥离一个,Hybrid可以剥离很多

总结

以上就是今天要讲的内容,本文仅仅简单介绍了VLAN、VXLAN和端口链路类型

posted @ 2021-07-01 21:17  学不会阿巴,留不住她  阅读(392)  评论(1编辑  收藏  举报