poj1703(并查集,维护两个集合)

Find them, Catch them
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 53671   Accepted: 16449

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

分析:这个题跟poj2492差不多。

#include<cstdio>
#include<cstring>
using namespace std;
int N;
int pre[200200];
void init()
{
    for(int i=0;i<=N*2;i++)
    pre[i]=i;
}
int find(int x)
{
    if(x!=pre[x])
    pre[x]=find(pre[x]);
    return pre[x];
}
void unit(int x,int y)
{
    int rx=find(x),ry=find(y);
    if(rx<ry) pre[ry]=pre[rx];
    else pre[rx]=pre[ry];
}
int judge(int x,int y)
{
    int rx=find(x),ry=find(y);
    if(rx==ry) return 1;
    return 0;
}
int main()
{
    int T,M;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&N,&M);
        int x,y;
        init();
        char s[10];
        while(M--)
        {
            scanf("%s",s);
            scanf("%d%d",&x,&y);
            if(s[0]=='A')
            {
                if(judge(x,y)||judge(x+N,y+N)) printf("In the same gang.\n");
                else if(judge(x,y+N)||judge(x+N,y)) printf("In different gangs.\n");
                else printf("Not sure yet.\n");
                
            }
            else
            {
                unit(x+N,y);
                unit(x,y+N);
            }
        }
    }
    return 0;
}
View Code

 

posted @ 2018-10-01 10:34  ACRykl  阅读(117)  评论(0编辑  收藏  举报