PAT 1005. Spell It Right

PAT 1005. Spell It Right (20)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

代码如下

#include<iostream>
#include<vector>
using namespace std;
int main(){
	vector<string> map{"zero","one","two","three","four",
	                   "five","six","seven","eight","nine"};
	string s;
	cin>>s;
	int sum=0;
	for(int i=0;i<s.size();i++)
	sum+=s[i]-'0';
	s=to_string(sum);
	for(int i=0;i<s.size();i++)
	i>0?cout<<" "<<map[s[i]-'0']:cout<<map[s[i]-'0'];
	return 0;
}
posted @ 2018-01-03 22:37  A-Little-Nut  阅读(115)  评论(0编辑  收藏  举报