PAT 1029. 旧键盘

PAT 1029. 旧键盘

旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及实际被输入的文字,请你列出肯定坏掉的那些键。

输入格式:

输入在2行中分别给出应该输入的文字、以及实际被输入的文字。每段文字是不超过80个字符的串,由字母A-Z(包括大、小写)、数字0-9、以及下划线“_”(代表空格)组成。题目保证2个字符串均非空。

输出格式:

按照发现顺序,在一行中输出坏掉的键。其中英文字母只输出大写,每个坏键只输出一次。题目保证至少有1个坏键。

输入样例:

7_This_is_a_test
_hs_s_a_es

输出样例:

7TI

分析

用了C语言中的标准函数库中的strchr()函数可以实现查找字符串中的某个字符。

头文件: #include <string.h>

函数原型:char *strchr(const char *s, int c);

函数说明:从左向右,在字符串s中查找字符c首次出现的位置,如果找到返回c在s中的位置(指针),否则返回NULL

代码如下.

#include<iostream>
#include<algorithm>
#include<cctype> 
#include<string.h>
using namespace std;
int main(){
	char input1[81],input2[81],broken[81]={0};
	scanf("%s%s",&input1,&input2);
	int t1=0,t2=0,t=0;
	while(input2[t2]!='\0'){
	if(input1[t1]!=input2[t2]){
	if(isalpha(input1[t1]))
	input1[t1]=toupper(input1[t1]); 
	if(!strchr(broken,input1[t1]))
	broken[t++]=input1[t1];
	t1++;	
	}	
	else{
	t1++; t2++;
	}
	}
    while(input1[t1]!='\0'){
    if(isalpha(input1[t1]))
	input1[t1]=toupper(input1[t1]);
	if(!strchr(broken,input1[t1]))
	broken[t++]=input1[t1];
	t1++;		
	}
	printf("%s",broken);
	return 0;
}
posted @ 2017-12-24 17:58  A-Little-Nut  阅读(308)  评论(0编辑  收藏  举报