docker-compose升级

最近在使用docker-compose部署SkyWalking的时候,因docker-compose版本太久不支持3.8版本的语法,出现了报错。需我们单独将compose升级版本,升级步骤如下👇:

  • 下载,命令如下👇:
sudo curl -L https://get.daocloud.io/docker/compose/releases/download/1.26.2/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose

因Github国内访问不太稳定所以使用DaoCloud提供加速:链接,你可以通过URL中的版本号,自定义下载你所需要的版本文件。

  • 对命令进行一个授权
sudo chmod +x /usr/local/bin/docker-compose
  • 查看compose版本命令
docker-compose --version
  • 卸载
sudo rm /usr/local/bin/docker-compose

参考链接

参考

posted @ 2020-11-12 15:47  自在拉基  阅读(902)  评论(0编辑  收藏