Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 10^4^ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=10^4^, the total number of coins) and M(<=10^2^, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V~1~ <= V~2~ <= ... <= V~k~ such that V~1~ + V~2~ + ... + V~k~ = M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k >= 1 such that A[i]=B[i] for all i < k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution


dfs加剪枝,先整体排序,把比m大的去掉,如果加到一个数比m大了就返回,每一步同一个数只算一次,比如说到了i步,选了第j个数,继续dfs,当返回到这里时,继续尝试i+1,如果i+1和i相同直接跳,因为在后边已经测试过这种情况了。
也可以一开始就计算总和,如果总的和小于m就不用dfs了。
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;
int n,m;
int s[10000],ans[10000];
int flag;
void dfs(int k,int last,int sum) {
    if(flag)return;
    if(sum > m)return;
    if(sum == m) {
        flag = k;
        return;
    }
    for(int i = last;i < n;i ++) {
        if(flag)return;
        if(i != last && s[i] == s[i - 1])continue;
        ans[k] = s[i];
        dfs(k + 1,i + 1,sum + s[i]);
    }
}
int main() {
    scanf("%d%d",&n,&m);
    for(int i = 0;i < n;i ++) {
        scanf("%d",&s[i]);
    }
    sort(s,s + n);
    while(s[n - 1] > m)n --;
    dfs(0,0,0);
    if(!flag)printf("No Solution\n");
    else {
        printf("%d",ans[0]);
        for(int i = 1;i < flag;i ++) {
            printf(" %d",ans[i]);
        }
    }
}