定义一个二维数组:

int maze[5][5] = {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

简单bfs求得最短路径

代码:
#include <iostream>
#include <cstdio>
#include <queue>
#include <map>
#include <algorithm>
struct que {
    int x,y,f;///xy是坐标 f是父结点
}s[100];
int dir[4][2] = {0,1,1,0,0,-1,-1,0};//四个方向
int mp[5][5],vis[5][5];
void print(int t) {///输出路径
    if(s[t].f != -1) print(s[t].f);
    printf("(%d, %d)\n",s[t].x,s[t].y);
}
int main() {
    int head = 0,tail = 0;
    for(int i = 0;i < 5;i ++)
        for(int j = 0;j < 5;j ++)
            scanf("%d",&mp[i][j]);
    s[tail].x = 0;
    s[tail].y = 0;
    s[tail].f = -1;
    tail ++;
    while(head < tail) {
        for(int i = 0;i < 4;i ++) {
            int tx = s[head].x + dir[i][0];
            int ty = s[head].y + dir[i][1];
            if(tx < 0 || ty < 0 || tx > 4 || ty > 4 || mp[tx][ty] || vis[tx][ty]) continue;
            s[tail].x = tx;
            s[tail].y = ty;
            s[tail].f = head;
            vis[tx][ty] = 1;
            tail ++;
        }
        head ++;
        if(s[tail-1].x + s[tail-1].y == 8) {
            print(tail - 1);
            break;
        }
    }
    return 0;
}