A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

 

  • The left subtree of a node contains only nodes with keys less than the node's key.

     

     

  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

     

     

  • Both the left and right subtrees must also be binary search trees.

     

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    10
    1 2 3 4 5 6 7 8 9 0
    
     

    Sample Output:

    6 3 8 1 5 7 9 0 2 4

给出一个序列,从小到大排序就是树的中序遍历,不妨中序遍历走一遍把各个结点放在各自的位置。由于是完全二叉树,可以用数组按顺序来存,完事输出数组就是层序遍历。

 

代码:

 

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int n,l[1001],tr[2010],c;
void inorder(int k) {
    if(k > n)return;
    inorder(k * 2);
    tr[k] = l[c ++];
    inorder(k * 2 + 1);
}
void levelprint() {
    for(int i = 1;i <= n;i ++) {
        if(i == 1) printf("%d",tr[i]);
        else printf(" %d",tr[i]);
    }
}
int cmp(const void *a,const void *b) {
    return *(int *)a - *(int *)b;
}
int main() {
    scanf("%d",&n);
    for(int i = 0;i < n;i ++)
        scanf("%d",&l[i]);
    qsort(l,n,sizeof(l[0]),cmp);
    inorder(1);
    levelprint();
}