AI.jpg

以上图片来自新浪微博。

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

  • 无论用户说什么,首先把对方说的话在一行中原样打印出来;
  • 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
  • 把原文中所有大写英文字母变成小写,除了 I
  • 把原文中所有独立的 can youcould you 对应地换成 I canI could—— 这里“独立”是指被空格或标点符号分隔开的单词;
  • 把原文中所有独立的 I 和 me 换成 you
  • 把原文中所有的问号 ? 换成惊叹号 !
  • 在一行中输出替换后的句子作为 AI 的回答。

输入格式:

输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:

按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:

6
Hello ?
 Good to chat   with you
can   you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know
 

输出样例:

Hello ?
AI: hello!
 Good to chat   with you
AI: good to chat with you
can   you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know

考完研来补题,当时比赛没做出来,只得了部分分,说到底是考虑的情况不全。
补一下样例
输入:
7
?
can you?
I 'm your father !
can .
can
I?
me.
输出(AI部分):
AI: !
AI: I can!
AI: you'm your father!
AI: can.
AI: can
AI: you!
AI: you.

代码:
#include <stdio.h>
#include <string.h>
#include <ctype.h>
int n,len;
char s[1050],t[1050];
void print(char *str,int *c) {
    if(!isalnum(str[*c])) {
        printf("%c",str[*c]);
        *c += 1;
        if(str[*c] == ' ') *c += 1;
        return;
    }
    if(*c && str[*c - 1] == ' ') printf(" ");
    char temp1[1050],temp2[1050] = "";
    sscanf(str + *c,"%s",temp1);
    if(strcmp(temp1,"I") == 0 || strcmp(temp1,"me") == 0) {
        printf("you");
        *c += strlen(temp1) + 1;
    }
    else if(strcmp(temp1,"can") == 0 || strcmp(temp1,"could") == 0) {
        *c += strlen(temp1) + 1;
        if(*c < len) {
            sscanf(str + *c,"%s",temp2);
        }
        if(strcmp(temp2,"you") == 0) {
            printf("I %s",temp1);
            *c += strlen(temp2) + 1;
        }
        else printf("%s",temp1);
    }
    else {
        printf("%s",temp1);
        *c += strlen(temp1) + 1;
    }
}
int main() {
    scanf("%d",&n);
    getchar();
    for(int i = 0;i < n;i ++) {
        int k = 0,c = 0;
        while((s[k] = getchar()) != '\n') {
            if(s[k] == ' ') {
                if(c && t[c - 1] != ' ') t[c ++] = ' ';
            }
            else if(!isalnum(s[k])) {
                if(c && t[c - 1] != ' ') t[c ++] = ' ';
                if(s[k] == '?') t[c ++] = '!';
                else t[c ++] = s[k];
            }
            else {
                if(s[k] != 'I') t[c ++] = tolower(s[k]);
                else t[c ++] = s[k];
            }
            k ++;
        }
        while(t[c - 1] == ' ') c --;
        s[k] = 0;
        t[c] = 0;
        printf("%s\nAI: ",s);
        len = c;
        c = 0;
        while(c < len) {
            print(t,&c);
        }
        printf("\n");
    }
    return 0;
}