Description

For this problem, you will write a program that reads in a sequence of 32-bit signed integers. After each odd-indexed value is read, output the median (middle value) of the elements received so far.

Input

The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by an odd decimal integer M, (1 ≤ M ≤ 9999), giving the total number of signed integers to be processed. The remaining line(s) in the dataset consists of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.

Output

For each data set the first line of output contains the data set number, a single space and the number of medians output (which should be one-half the number of input values plus one). The output medians will be on the following lines, 10 per line separated by a single space. The last line may have less than 10 elements, but at least 1 element. There should be no blank lines in the output.

Sample Input

3 
1 9 
1 2 3 4 5 6 7 8 9 
2 9 
9 8 7 6 5 4 3 2 1 
3 23 
23 41 13 22 -3 24 -31 -11 -8 -7 
3 5 103 211 -311 -45 -67 -73 -81 -99 
-33 24 56

Sample Output

1 5
1 2 3 4 5
2 5
9 8 7 6 5
3 12
23 23 22 22 13 3 5 5 3 -3 
-7 -3

Source

 
要动态的求中位数,可以维护两个堆,一个大顶堆和一个小顶堆,各自装一半的元素,那么中位数就可以在堆顶找到,因为只有在index为奇数的时候才查询中位数,此时一共有奇数个数,所以一个堆比另一个堆多一个数,这个可以自选,如果选择大顶堆多一个数,那么它的堆顶就是中位数,反之是小顶堆,小顶堆里的元素都不小于它的堆顶元素,大顶堆里的元素都不大于它的堆顶,小顶堆里的元素大于等于大顶堆里的任何一个元素。
 
代码:
#include <iostream>
#include <cstdio>
#include <queue>

using namespace std;

int main() {
    int p,sn,m,d;
    scanf("%d",&p);
    while(p --) {
        priority_queue<int,vector<int>,less<int> > qg;
        priority_queue<int,vector<int>,greater<int> > ql;
        scanf("%d%d",&sn,&m);
        printf("%d %d\n",sn,(m + 1) / 2);
        for(int i = 1;i <= m;i ++) {
            scanf("%d",&d);
            if(qg.empty() || d < qg.top()) qg.push(d);
            else ql.push(d);
            while(ql.size() > qg.size()) {
                qg.push(ql.top()); ql.pop();
            }
            while(qg.size() > ql.size() + 1) {
                ql.push(qg.top()); qg.pop();
            }
            if(i % 2) {
                printf("%d",qg.top());
                if((i + 1) % 20 == 0 || i == m) putchar('\n');
                else putchar(' ');
            }
        }
    }
}