D-We Love MOE Girls

D - We Love MOE Girls
Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Chikami Nanako is a girl living in many different parallel worlds. In this problem we talk about one of them. 
In this world, Nanako has a special habit. When talking with others, she always ends each sentence with "nanodesu". 
There are two situations: 
If a sentence ends with "desu", she changes "desu" into "nanodesu", e.g. for "iloveyoudesu", she will say "iloveyounanodesu". Otherwise, she just add "nanodesu" to the end of the original sentence. 
Given an original sentence, what will it sound like aften spoken by Nanako?
 

Input

The first line has a number T (T <= 1000) , indicating the number of test cases. 
For each test case, the only line contains a string s, which is the original sentence. 
The length of sentence s will not exceed 100, and the sentence contains lowercase letters from a to z only.
 

Output

For every case, you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output which Nanako will say.
 

Sample Input

2 ohayougozaimasu daijyoubudesu
 

Sample Output

Case #1: ohayougozaimasunanodesu Case #2: daijyoubunanodesu
 
#include<stdio.h>
#include<string.h>
int main()
{
    int T, len, i, j;
    char s[102];
    scanf("%d", &T);
   for(j=1; j<=T;j++)
    {
        scanf("%s", s);
        len = strlen(s);
        if( s[len-4]=='d' && s[len-3]=='e' && s[len-2]=='s' && s[len-1]=='u')
        {
            printf("Case #%d: ", j);
            for(i=0;i<(len-4); i++)
                printf("%c", s[i]);
            printf("nanodesu\n");
        }
        else
        {
            printf("Case #%d: ", j);
            for(i=0; i<len; i++)
                printf("%c", s[i]);
            printf("nanodesu\n");
        }

    }
    return 0;
}


posted @ 2014-02-13 21:26  6bing  阅读(141)  评论(0编辑  收藏  举报