hdu 1040 As Easy As A+B

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60774    Accepted Submission(s): 26130


Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
 

 

Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.
 

 

Output
For each case, print the sorting result, and one line one case.
 

 

Sample Input
2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
 

 

Sample Output
1 2 3 1 2 3 4 5 6 7 8 9
 
这个题目完全没有难度,学会了sort就可以了
看代码就ok了
#include <stdlib.h>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
int a[10005];
int main() {
  int t,n;
  cin>>t;
  while(t--)
  {
      cin>>n;
      for(int i=0;i<n;i++)
      {
          cin>>a[i];
      }
      sort(a,a+n);
      for(int i=0;i<n-1;i++)
      {
          printf("%d ",a[i]);
      }
      printf("%d\n",a[n-1]);
  }
    return 0;
}
posted @ 2017-03-17 10:44  红雨520  阅读(159)  评论(0编辑  收藏  举报