第三次实验报告:使用Packet Tracer分析TCP连接建立过程

目录

1 实验目的

  • 使用路由器连接不同的网络
  • 使用命令行操作路由器
  • 通过抓取HTTP报文,分析TCP连接建立的过程

2 实验内容

使用Packet Tracer,正确配置网络参数,通过抓取HTTP数据包,分析TCP连接建立过程。

  • 建立网络拓扑结构
  • 配置参数
  • 抓包
  • 分析数据包

3. 实验报告

实验报告要求:独立完成,不得抄袭。在截止日期前提交。

在博文开头给出你的个人信息

  • 姓名   邹文兵
  • 学号   201821121028
  • 班级   计算1811

3.1 建立网络拓扑结构

网络拓扑图如下图所示:

网络拓扑图

3.2 配置参数

  • 客户端的IP地址为192.168.1.28
  • 服务端的IP地址为192.168.1.28。

给出路由器参数配置的详细操作,解释每条命令的功能。

1.客户端PC0的参数设置:

   IP Address处设置客户端的IP地址192.168.1.28

   Default Gateway处设置客户端到路由器的默认网关为192.168.1.29

 

2.服务器Service0的参数设置:

   IP Address处设置服务端的IP地址192.168.2.28

   Default Gateway处设置服务端到路由器的默认网关为192.168.2.29

 

3.路由器参数设置:

清除路由器现有配置:

Router>enable                                       #进入特权执行模式

Router#erase startup-config                  #清除路由器现有配置

Router#configure terminal                     #进入全局配置模式

Router(config)#no ip domain-lookup     #禁用DNS查找

配置并激活端口:

Router>enable                                       #进入特权执行模式

Router#configure terminal                     #进入全局配置模式

Router(config)#hostname R                  #将路由器名字配置为R

配置G0/0接口:

R(config)#interface G0/0                       

R(config-if)#ip address 192.168.1.29 255.255.255.0

R(config-if)#no shutdown                      #激活接口

R(config-if)#exit                                     #退出G0/0接口配置

配置F0/0接口:

R(config)#interface G0/1                      

R(config-if)#ip address 192.168.2.29 255.255.255.0

R(config-if)#no shutdown                      #激活接口

R(config-if)#exit                                     #退出G0/1接口配置

配置路由器算法:

R(config)#router rip                               #启动动态路由

R(config-router)#version 2                    #使用rip 2版本

R(config-router)#no auto-summary      #关闭自动路由汇总

指定网络:

R(config-router)#network 192.168.1.0

R(config-router)#network 192.168.2.0

3.3 抓包,分析TCP连接建立过程

通过抓取HTTP数据包得到的TCP报文,完成如下事情:

抓包过程:

 

 

 

TCP报文:

 

 

 

 TCP报文的分析:

SOURCE PORT:源端口

DESTINATION PORT:目的端口

SEQUENCE NUMBER:序号

ACKNOWLEDGEMENT NUMBER:确认号

OFFSET:数据偏移 

RESERVED:保留   

WINDOW:窗口

CHECKSUM:检验和  

UEGENT POINTER:紧急指针

OPTION:选项 

PADDING:填充

FLAGS :

   URG:紧急指针标志

  ACK:确认序号标志

  PSH:push标志

  RST:重置连接标志

  SYN:同步序号,用于建立连接过程

  FIN:结束标志,用于释放连接

(1)画出TCP连接建立示意图

如下图所示:

 

(2)分析序号和确认号的变化

第一次握手:

pc机向服务器发出连接请求报文段,此时SYN=1,初始序号seq=0。

第二次握手:

服务器收到请求连接报文段并同意连接,向PC机发送确认,ACK=1,同时初始序号seq=0。

第三次握手:

PC机收到确认后,向服务器发送确认,确认报文段ACK=1,序号seq=1,TCP建立连接。

(3)解答:为什么连接建立需要第三次握手

答:为防止了以失效的连接请求报文段突然又传送到B,因而产生错误。

4. 拓展 (不作要求,但属于加分项)

(1)分析TCP连接释放

画出TCP连接释放示意图,结合课本内容,解释图为什么会跟课本不一样。解答为什么连接释放需要四次握手。

(2)通过该实验如果有产生新的疑问,可以写出来,并尝试自己解决问题

posted @ 2019-10-19 23:56  zouwenbin  阅读(337)  评论(0编辑  收藏  举报