poj1096-Collecting Bugs

Collecting Bugs
Time Limit: 10000MS   Memory Limit: 64000K
Total Submissions: 1696   Accepted: 769
Case Time Limit: 2000MS   Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

地址:http://poj.org/problem?id=2096

看了好久题,到底没看懂,看了别人写的题意。。。。。。。。。
提的大意是一共有s个系统,n种bug,每天只能找到一种bug。想要找到n种bug且每个系统都至少检查出一个bug的天数期望。(访问s种哪个系统和能够找到哪种bug都是随机的)
思路:用dp[i][j]来表示找到了i种bug,访问过s个系统的天数期望值。所以分四种情况
dp[i][j]:i,j都没变,表示第二天在已找过的i个bug里j个系统中又找了一个bug,所以p1=i/n*j/s;
dp[i+1][j]:i+1,表示在n-i中找了一个bug所以是(n-i)/n,j没变,即还是j/s,所p2=(n-i)/n*j/s;
dp[i][j+1]:i没变,同上i/n,j+1即在s-j中找了一个bug,(s-j)/s,所以p3=i/n*(s-j)/s;
dp[i+1][j+1]:同理,p4=(n-i)/n*(s-j)/s;
这就可以看出状态转移方程了:dp[i][j]=p1*dp[i][j]+p2*dp[i+1][j]+p3*dp[i][j+1]+p4*dp[i+1][j+1]+1;(不要忘了+1)
代码:
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
#include <vector>
#include <queue>
#include <algorithm>
#define LL long long
#define M 1010
using namespace std;
double dp[M][M];
int main()
{
    int n,s;
    while(scanf("%d%d",&n,&s)!=EOF){
        dp[n][s]=0;
        for(int i=n;i>=0;i--){
            for(int j=s;j>=0;j--){
                if(i==n&&j==s)continue;
                dp[i][j]=(i*(s-j)*dp[i][j+1]+(n-i)*j*dp[i+1][j]+(n-i)*(s-j)*dp[i+1][j+1]+n*s)/(n*s-i*j);
            }
        }
        printf("%.4lf\n",dp[0][0]);
    }
    return 0;
}
View Code

 






posted @ 2013-08-14 17:13  SunnySnail  阅读(151)  评论(0编辑  收藏  举报