hoj1030-Labyrinth

Labyrinth

My Tags   (Edit)
  Source : ACM ICPC Central European Regional 1999
  Time limit : 5 sec   Memory limit : 32 M

Submitted : 797, Accepted : 337

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.

Input Specification

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly Rlines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth.

The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.

Output Specification

Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X. where Xis the length of the longest path between any two free blocks, measured in blocks.

Sample Input:
2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######
Sample Output:
Maximum rope length is 0.
Maximum rope length is 8.


地址:http://acm.hit.edu.cn/hoj/problem/view?id=1030
折磨了我好久没有思路的题,今天看了一下题解,恍然大悟。。。。。。。。两次搜索bfs,第一次搜索最长路的端点,第二次从端点开始bfs,搜出来的ans就是最长路了,就是这里怎么也没想通,一次搜索无法实现嘛。。。。。。。。
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
int dir[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
struct data{
    int x,y,cnt;
};
queue<data>q;
data p,f;
int n,m,vis[1000][1000],s[1000][1000],xx,yy,ans;
void bfs(int a,int b,int c){
    vis[a][b]=c;
    p.x=a;p.y=b;
    p.cnt=0;
    while(!q.empty())q.pop();
    q.push(p);
    while(!q.empty()){
        p=q.front();
        q.pop();
        for(int i=0;i<4;i++){
            f.x=p.x+dir[i][0];
            f.y=p.y+dir[i][1];
            if(f.x<0||f.y<0||f.x>=m||f.y>=n)continue;
            if(s[f.x][f.y]==0&&vis[f.x][f.y]!=c){
                vis[f.x][f.y]=c;
                f.cnt=p.cnt+1;
                if(ans<f.cnt){
                    ans=f.cnt;
                    xx=f.x;
                    yy=f.y;
                    //printf("%d %d\n",xx,yy);
                }
                q.push(f);
            }
        }
    }
    //printf("%d\n",ans);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        memset(vis,0,sizeof(vis));
        char ch;
        ans=0;
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
            {
                scanf(" %c",&ch);
                if(ch=='.')s[i][j]=0;
                else s[i][j]=1;
            }
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
                if(s[i][j]==0&&vis[i][j]==0)
                    bfs(i,j,1);
        bfs(xx,yy,2);
        printf("Maximum rope length is %d.\n",ans);
    }
    return 0;
}
View Code

 

posted @ 2013-08-06 15:20  SunnySnail  阅读(264)  评论(0编辑  收藏  举报