hdu4632 Palindrome subsequence

Palindrome subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65535 K (Java/Others)
Total Submission(s): 2280    Accepted Submission(s): 913


Problem Description
In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <Sx1, Sx2, ..., Sxk> and Y = <Sy1, Sy2, ..., Syk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if Sxi = Syi. Also two subsequences with different length should be considered different.
 

 

Input
The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.
 

 

Output
For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.
 

 

Sample Input
4 a aaaaa goodafternooneveryone welcometoooxxourproblems
 

 

Sample Output
Case 1: 1 Case 2: 31 Case 3: 421 Case 4: 960
 

 

Source
dp[i][j] 表示 包含 a[i]的,到 j 的回文个数
转移:
dp[i][j] = 1 ;
dp[i][j] = dp[i][j-1] ; i < j
if(a[i]==a[j]) dp[i][j] += dp[k][j-1]  ; i < k < j 
这样是n^3的,会T
所以用 sum[i][j] 表示到回文个数,优化转移
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#define maxn 100010
#define LL long long
#define mod 10007
using namespace std;

int dp[1010][1010],sum[1010][1010];
char a[1010] ;
int main()
{
    int n,i,j,m;
    int T,case1=0;
    cin >> T ;
    while( T-- )
    {
        scanf("%s",a+1) ;
        n = strlen(a+1) ;
        memset(dp,0,sizeof(dp)) ;
        memset(sum,0,sizeof(sum)) ;
        for( i = n ; i >= 1 ;i--)
            for( j = i ; j <= n ;j++)
        {
            if(i==j)
            {
                dp[i][j]=1;
                sum[i][j]=1;
                continue;
            }
            dp[i][j] = dp[i][j-1] ;
            if(a[i]==a[j])
            {
                dp[i][j]++;
               // for(int k = i+1 ; k < j ;k++)
                   // dp[i][j] += dp[k][j-1];
                   dp[i][j] += sum[i+1][j-1] ;
            }
            dp[i][j] %= mod;
            sum[i][j] = (sum[i+1][j]+dp[i][j])%mod;
        }
        int ans=0;
        for(i = 1 ; i <= n ;i++)
            ans = (ans+dp[i][n])%mod ;
        printf("Case %d: %d\n",++case1,ans);
    }
    return 0;
}

  

posted @ 2014-08-09 20:19  _log__  阅读(148)  评论(0编辑  收藏  举报