hdu4336 Card Collector

Card Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1910    Accepted Submission(s): 888
Special Judge


Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
 

 

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks.

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
 

 

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
 

 

Sample Input
1 0.1 2 0.1 0.4
 

 

Sample Output
10.000 10.500
 

 

Source
 

 

Recommend
zhoujiaqi2010
//dp[1111] 表示 4 包都没有的期望 所以 == 0 
//4包都没有,我们可以拿一包,就会变成dp[0111] , dp[1011] , dp[1101] , dp[1110]
// 所以dp[0111] = (1+dp[1111]*p[0])/p[0] ; ( +1 是因为拿了一包)
//类似的 dp[01010] 等 可以由他那位为 0 补上 1 转移而来 
//最后答案就是 dp[000..] 

#include<iostream>
#include<cstdio>
#include<cstring>
#define maxn (1<<21)
using namespace std ;

double dp[maxn] , p[23];

int main()
{
    int i , n , j , k ;
    double sum , m ;
    while( cin >> n )
    {
        for( i = 0 ; i < n ;i++ )
            scanf("%lf",&p[i]) ;
        dp[(1<<n)-1] = 0 ;
        for( i = (1<<n)-2 ; i >= 0 ;i-- )
        {
            dp[i] = 1.0 ;
            sum = 0.0;
            for( j = 0 ; j < n ;j++ )
                if(!(i&(1<<j)))
            {
                dp[i] += dp[i|(1<<j)]*p[j] ;
                sum += p[j] ;
            }
            dp[i] /= sum ;
        }
        printf("%lf\n",dp[0]) ;
    }
}

 

posted @ 2013-10-18 18:06  _log__  阅读(135)  评论(0编辑  收藏  举报