bzoj3261

3261: 最大异或和

Time Limit: 10 Sec  Memory Limit: 512 MB
Submit: 1726  Solved: 728
[Submit][Status][Discuss]

Description

     

给定一个非负整数序列 {a},初始长度为 N。       
有   M个操作,有以下两种操作类型:
 
1 、A x:添加操作,表示在序列末尾添加一个数 x,序列的长度 N+1。
2 、Q l r x:询问操作,你需要找到一个位置 p,满足 l<=p<=r,使得:
 
a[p] xor a[p+1] xor ... xor a[N] xor x 最大,输出最大是多少。  

Input

第一行包含两个整数 N  ,M,含义如问题描述所示。   
第二行包含 N个非负整数,表示初始的序列 A 。 
 
接下来 M行,每行描述一个操作,格式如题面所述。   

Output

假设询问操作有 T个,则输出应该有 T行,每行一个整数表示询问的答案。

Sample Input

5 5
2 6 4 3 6
A 1
Q 3 5 4
A 4
Q 5 7 0
Q 3 6 6
对于测试点 1-2,N,M<=5 。

对于测试点 3-7,N,M<=80000 。
对于测试点 8-10,N,M<=300000 。

其中测试点 1, 3, 5, 7, 9保证没有修改操作。
对于 100% 的数据, 0<=a[i]<=10^7。

Sample Output

4
5
6

HINT

 

对于      100%  的数据,     0<=a[i]<=10^7  。

 

Source

这题搞了三个小时大概是没救了。。。

看见疑惑最大,我们就要想到trie。为什么?因为异或保证这个数字不会超出给定范围,而且异或可以按位计算,也就是可以做到log级别的查询,然后字典树的尿性很符合这种把数字二进制拆分的套路,那么我们就可以用字典树做了。

怎么做呢?这里用了可持久化trie。如果你学过了主席树,那么这个也很好理解,看看代码就发现很像。

化简:max(a[i] xor a[i+1] xor ... xor a[n]) 设b[n] = a[1] xor ... xor a[n]

即所求为 max(b[n] xor x xor a[i]) (l-1<=i<=r)

因为二进制有个特性:最高位为1的数比最高位为0的数大。那么我们就可以按位贪心,从高位到低位,如果有高位为1的数,那么必然选这个数,然后继续贪心下一位。

怎么判断有最高位为1的数呢?

#include<bits/stdc++.h>
using namespace std;
const int N = 600010;
int n, m, cnt;
int bit[30], b[N], a[N];
struct trie {
    int size[N * 24], child[N * 24][2] ,root[N];
    int build()
    {
        int x = ++cnt, ret = x, val = 1; 
        for(int i = 23; i >= 0; --i)
        {
            int t = val & bit[i]; t >>= i;
            size[x] = 1;
            child[x][t] = ++cnt;
            x = child[x][t];
        }
        size[x] = 1; return ret;
    }
    int ins(int last, int val)
    {
        int ret = ++cnt, x = ret;
        for(int i = 23; i >= 0; --i)
        {
            child[x][0] = child[last][0];
            child[x][1] = child[last][1];
            size[x] = size[last] + 1;
            int t = val & bit[i]; t >>= i;
            child[x][t] = ++cnt;
            x = child[x][t]; last = child[last][t];
        }
        size[x] = size[last] + 1;
        return ret;
    }
    int query(int l, int r, int val)
    {
        int ret = 0;
        for(int i = 23; i >= 0; --i)
        {
            int t = val & bit[i]; t >>= i;
            if(size[child[r][t ^ 1]] - size[child[l][t ^ 1]]) { ret += bit[i]; r= child[r][t ^ 1]; l = child[l][t ^ 1]; }
            else { r = child[r][t]; l = child [l][t]; }
        }
        return ret;
    }
} t;
int main()
{
    scanf("%d%d", &n, &m); ++n;
    bit[0] = 1;
    for(int i = 1; i < 30; ++i) bit[i] = bit[i - 1] << 1;
    for(int i = 2; i <= n; ++i) scanf("%d", &a[i]);
    for(int i = 1; i <= n; ++i) b[i] = b[i - 1] ^ a[i];
    for(int i = 1; i <= n; ++i) t.root[i] = t.ins(t.root[i - 1], b[i]);
    while(m--)
    {
        char s[10]; int l, r, x; scanf("%s", s);
        if(s[0] == 'A') 
        {
            ++n; scanf("%d", &a[n]); b[n] = b[n - 1] ^ a[n];
            t.root[n] = t.ins(t.root[n - 1], b[n]);
        }       
        if(s[0] == 'Q')
        {
            scanf("%d%d%d", &l, &r, &x);
            printf("%d\n", t.query(t.root[l - 1], t.root[r], b[n] ^ x));
        }
    }   
    return 0;
}
View Code

 

posted @ 2017-03-24 18:24  19992147  阅读(142)  评论(0编辑  收藏  举报