poj 1840 枚举

Eqs
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 13967   Accepted: 6858

Description

Consider equations having the following form:
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 The coefficients are given integers from the interval [-50,50]. It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.
Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

Source

 

 

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int hash[1000000];
int main(){
    int a,b,c,d,e;
    while(cin>>a>>b>>c>>d>>e){
        memset(hash,0,sizeof(hash));
        int cnt=0;
        for(int i=-50;i<=50;i++){
            if(i==0)
                continue;
            for(int j=-50;j<=50;j++){
                if(j==0)
                    continue;
                for(int k=-50;k<=50;k++){
                    if(k==0)
                        continue;
                    int temp=i*i*i*a+j*j*j*b+k*k*k*c;
                  hash[cnt++]=temp;
                }
            }
        }
        int ans=0;
                sort(hash,hash+cnt);
        for(int i=-50;i<=50;i++){
            if(i==0)
                continue;
            for(int j=-50;j<=50;j++){
                if(j==0)
                    continue;
                int temp2=i*i*i*e+j*j*j*d;
                ans+=upper_bound(hash,hash+cnt,temp2)-lower_bound(hash,hash+cnt,temp2);
            }
        }

        printf("%d\n",ans);

    }
    return 0;
}

 

posted @ 2015-08-03 23:51  柳下_MBX  阅读(427)  评论(0编辑  收藏  举报