hdu 2492 树状数组 Ping pong

Ping pong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4589    Accepted Submission(s): 1681


Problem Description
N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment).

Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs.

The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?
 

 

Input
The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case.


Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 … aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 … N).
 

 

Output
For each test case, output a single line contains an integer, the total number of different games.
 

 

Sample Input
1 3 1 2 3
 

 

Sample Output
1
 

 

Source
 

 

Recommend
gaojie   |   We have carefully selected several similar problems for you:  2485 2491 2490 2489 2488 
 
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct node{
    int u,v,m,h;
}que[100005];
bool cmp(struct node t1,struct node t2){
     if(t1.m==t2.m)
        return t1.u<t2.u;
     else
        return t1.m<t2.m;
}
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
            if(n==0)
            break;
    for(int i=0;i<n;i++){
        scanf("%d%d",&que[i].u,&que[i].v);
        que[i].h=(que[i].v-que[i].u)/2+1;
        que[i].m=que[i].u+que[i].h;
    }
    sort(que,que+n,cmp);
    int flag=0;
    for(int i=0;i<n-1;i++){
            if(que[i].m>=que[i+1].m){
                flag=1;
                break;
            }
        if(que[i].m<que[i+1].u)
            continue;
        double temp=que[i].m-que[i+1].u;
        que[i+1].m=temp+que[i+1].h+que[i+1].u;
    }
    if(flag)
        printf("NO\n");
    else
        printf("YES\n");


    }
   return 0;
}

 

posted @ 2015-07-27 18:54  柳下_MBX  阅读(671)  评论(0编辑  收藏  举报