hdu 1171

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26534    Accepted Submission(s): 9332


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

 

Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

 

Sample Output
20 10 40 40
 

 

Author
lcy
 

 背包。

所有的设备不是放在第一部分,就是要放在第二部分。

那么对于第一部分,或者第二部分,每一个设备就只有放和不放两种情况。

然后感觉就是做一个容量为总数的一半的01背包

然后脑抽看到第一部分可以大于一半,觉得这么想是错的。。。

实际上并不是,因为第二部分总要比第一部分小,所以第二部分是不可能大于一半的。

所以我们对于第二部分做01背包。

 

 

 

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cmath>

using namespace std;
const int N=3E6+5;
int a[N],dp[N];
int n,x,y;
int tmp;
int sum;

void solve(int value ,int cost)
{
    for ( int i = sum/2 ; i >= cost ; i--)
    {
        dp [i] = max(dp[i],dp[i-cost]+value);
    }

}

int main()
{
    while (scanf("%d",&n)!=EOF)
    {
        if( n<0 ) break;
        memset(dp,0,sizeof(dp));
        memset(a,0,sizeof(a));
        tmp = 1;
        sum = 0;
        for ( int i = 1 ; i <= n ; i++ )
        {
            scanf("%d %d",&x,&y);
            sum = sum +x*y;
            for ( int j =1 ; j <= y ; j++)
            {
                a[tmp] = x;
                tmp++;
            }
        }
        for ( int i = 1 ; i <= tmp ; i++)
            solve (a[i],a[i]);
        printf("%d %d\n",sum-dp[sum/2],dp[sum/2]);
    }

    return 0;
}

 

posted @ 2015-04-04 22:56  111qqz  阅读(135)  评论(0编辑  收藏  举报