hdu 1263 水果 【二维map】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1263

 

题目大意:

Problem Description
夏天来了~~好开心啊,呵呵,好多好多水果~~
Joe经营着一个不大的水果店.他认为生存之道就是经营最受顾客欢迎的水果.现在他想要一份水果销售情况的明细表,这样Joe就可以很容易掌握所有水果的销售情况了.
 


Input
第一行正整数N(0<N<=10)表示有N组测试数据.
每组测试数据的第一行是一个整数M(0<M<=100),表示工有M次成功的交易.其后有M行数据,每行表示一次交易,由水果名称(小写字母组成,长度不超过80),水果产地(小写字母组成,长度不超过80)和交易的水果数目(正整数,不超过100)组成.
 


Output
对于每一组测试数据,请你输出一份排版格式正确(请分析样本输出)的水果销售情况明细表.这份明细表包括所有水果的产地,名称和销售数目的信息.水果先按产地分类,产地按字母顺序排列;同一产地的水果按照名称排序,名称按字母顺序排序.
两组测试数据之间有一个空行.最后一组测试数据之后没有空行.
 


Sample Input
1
5
apple shandong 3
pineapple guangdong 1
sugarcane guangdong 1
pineapple guangdong 3
pineapple guangdong 1
 
 
Sample Output
guangdong
    |----pineapple(5)
    |----sugarcane(1)
shandong
    |----apple(3)
 
 
#include <algorithm>
#include <iostream>
#include <map>
#include <string>
using namespace std;
int main()
{
    int n, m, i,num,a;
    string loc, name;
    map<string, map<string, int>>Map;
    map<string, int>mmap;
    scanf("%d", &n);          
    while(n--)                 
    {
        Map.clear();
        scanf("%d", &m);
        for (i = 0; i < m; i++)
        {
            cin >> name >> loc >> num;
            Map[loc][name] += num;
        }
        map<string, map<string, int>>::iterator it;
        map<string, int>::iterator ii;
        for (it = Map.begin(); it != Map.end(); it++)
        {
            cout << it->first << endl;
            for (ii = it->second.begin(); ii != it->second.end(); ii++)
            {
                printf("   |----");                                              
                cout << ii->first << "(" << ii->second << ")"<<endl;
            }
        }
        if (n)printf("\n");                             //每组数据之间一个空格,最后一组数据后无空格
    }
    return 0;
}

 

2018-03-28
 
 
 
posted @ 2018-03-28 22:38  悠悠呦~  阅读(223)  评论(0编辑  收藏  举报
浏览器标题切换
浏览器标题切换end