Birthday Paradox

Birthday Paradox

Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.

Output

For each case, print the case number and the desired result.

Sample Input

2

365

669

Sample Output

Case 1: 22

Case 2: 30

题意 生日悖论
题解 百度百科关于生日悖论
水题。

#include<cstdio>
#include<algorithm>
#include<stack>
#include<queue>
#include<cstring>
using namespace std;
int main()
{    
    int t;
    scanf("%d",&t);
    int Case=1;
    while(t--)
    {
        double n;
        scanf("%lf",&n);
        double sum=1;
        int x=0;
        while(sum>0.5)
        {
            sum *=(n-x)/n; 
            x++;
        }
        printf("Case %d: %d\n",Case++,x-1);

     } 
    return 0;
}
posted @ 2017-07-31 10:42  岩扉  阅读(208)  评论(0编辑  收藏  举报