解决npm install 报错“npm WARN pug-loader@2.4.0 requires a peer of pug@^2.0.0 but none is installed. You must install peer dependencies yourself.“

npm install 的时候都报这个错误

 

 

npm更新了一下(我的版本是: 6.1.0),更新到了最新版本,这个问题就咋也没出现过了,原来是npm版本的问题。

查看自己的npm版本: npm -v

 

 

 

更新本机的npm到最新版本:npm install -g npm

然后 npm install 就没问题了。

posted @ 2021-04-07 15:02  一个人的孤独自白  阅读(48)  评论(0编辑  收藏  举报