poj1318 Word Amalgamation 字符串排序(qsort)

Word Amalgamation

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9794   Accepted: 4701

Description

In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.

Input

The input contains four parts: 1) a dictionary, which consists of at least one and at most 100 words, one per line; 2) a line containing XXXXXX, which signals the end of the dictionary; 3) one or more scrambled 'words' that you must unscramble, each on a line by itself; and 4) another line containing XXXXXX, which signals the end of the file. All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.

Output

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line "NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.

Sample Input

tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX

Sample Output

score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******

 

 

题目的意思是:给出一个以XXXXXX为结尾的字符串集作为字典,再输入一个以XXXXXX为结尾的字符串集作为要在字典中查找的目标字符串。判断目标字符串是否是由字典中的字符串经过变换得到的。

思路:按照字典序变换并记录 字符串集里面的每个字符串,对于目标字符串 也按字典序排列,并找出 与 排序后的目标字符串 相等的串存储其变换前对应字符串,按字典序排序后输出即可。

 

//poj1318
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
using namespace std;
 
#define N 105
#define M 10
char map[N][M];
char mark[N];
char s[N],ans[M];
int n,len;
bool vis[M],flag;
 
void dfs(int step)
{
    int i,j;
    if(step == len)
    {
        ans[len] = '\0';//字符串结束符
        for(j = 0; j < n; ++j)
        {
            if(!strcmp(map[j],ans) && !mark[j])
            {
                mark[j] = 1;
                printf("%s\n",map[j]);
                flag = 1;
                return ;
            }
        }
    }
    for(i = 0; i < len; ++i)
    {
        if(!vis[i])
        {
            vis[i] = 1;
            ans[step] = s[i];
            dfs(step+1);
            vis[i] = 0;
        }
    }
}
 
int cmp(const void * a,const void *b)
{
    return *(char *)a  - *(char *)b ;
}
 
int main()
{
    n = 0;
    while(scanf("%s",s)!=EOF)
    {
        if(!strcmp("XXXXXX",s))//这里的strcmp会按字典序比较
            break;
        else
            strcpy(map[n++],s); 
    }
    while(scanf("%s",s)!=EOF)
    {
        if(!strcmp("XXXXXX",s))
            break;
        len = strlen(s);
        qsort(s,len,sizeof(s[0]),cmp);//对字符串按字典序排序
        memset(vis,0,sizeof(vis));
        memset(mark,0,sizeof(mark));
        flag = 0;
        dfs(0);
        if(!flag)
            printf("NOT A VALID WORD\n");
        printf("******\n");
    }
    return 0;
}

 

posted @ 2018-08-19 12:16  知道了呀~  阅读(259)  评论(0编辑  收藏  举报