03 333(朱 :路由器配置(2)--骨干网络构建)

《计算机网络》上机实验报告

                                                                                                

专业和班级

2019级

成绩

 

姓名

朱 

学号

03 333

课程名称

计算机网络

实验名称

骨干网络构建

1. 理解路由协议的概念和分类;

2. 了解组网技术,搭建远程网络拓扑图;

3. 运用路由协议RIP、OSPF和BGP,实现骨干网络的联通。

简要解释下面网络术语。

1.简述路由协议routing protocol和被路由协议routed protocol的概念

答:

路由协议:路由协议(Routing protocol)是一种指定数据包转送方式的网上协议。Internet网络的主要节点设备是路由器,路由器通过路由表来转发接收到的数据。转发策略可以是人工指定的(通过静态路由、策略路由等方法)。在具有较小规模的网络中,人工指定转发策略没有任何问题。但是在具有较大规模的网络中(如跨国企业网络、ISP网络),如果通过人工指定转发策略,将会给网络管理员带来巨大的工作量,并且在管理、维护路由表上也变得十分困难。为了解决这个问题,动态路由协议应运而生。动态路由协议可以让路由器自动学习到其他路由器的网络,并且网络拓扑发生改变后自动更新路由表。网络管理员只需要配置动态路由协议即可,相比人工指定转发策略,工作量大大减少。

被路由协议:被路由协议是一些用于定义数据报内字段格式并且为用户的通讯传输提供一种机制的协议(也就是网络层地址中提供了足够的信息使得数据包能够根据编制方从一个主机传递到另一个主机的任何网络协议)的数据报可以被路由器转发到其他网络。被路由协议使用路由协议来寻址和转发数据包。

 2.简述路由协议的分类,并比较其特点

答:

1)内部网关协议

内部网关协议(IGPInterior Gateway Protocol),适用于单个ISP的统一路由协议的运行,一般由一个ISP运营的网络位于一个自治系统内,有统一的自治系统号,用来处理内部路由。RIPIGRPCisco私有协议)、EIGRPCisco私有协议)、OSPFIS-IS等都是内部网关协议。

RIP:是动态路由协议,基于距离矢量算法,利用跳数来作为计量标准。在带宽、配置和管理方面要求较低,主要适合于规模较小的网络中。

②IGRP:内部网关路由协议。属于Cisco的私有协议,最大跳数默认为100,现已被Cisco独立开发的EIGRP协议取代。

OSPFOSPF 适合在大范围的网络;组播触发式更新;收敛速度快;以开销作为度量值;OSPF协议的设计是为了避免路由环路。在使用最短路径的算法下,收到路由中的链路状态,然后生成路径,这样不会产生环路。

④IS-IS:中间系统到中间系统路由协议。属于链路状态路由协议。与OSPF协议相似,其使用最短路径优先SPFShortest Path First)算法进行路由计算。

2)域间路由协议

BGP:边界网关协议。为了维护各个ISP的独立利益,标准化组织制定了ISP间的路由协议BGP,其用来处理各ISP之间的路由传递。

与内部网关协议不同的是,其不在于发现和计算路由,而在于控制路由的传播和选择最佳路由。

3.简述管理距离AD、自治系统AS的概念。

答:

管理距离(administrative distance):管理距离是指一种路由协议的路由可信度。每一种路由协议按可靠性从高到低,依次分配一个信任等级,这个信任等级就叫管理距离。

自治系统(autonomous system):在互联网中,一个自治系统(AS)是一个有权自主地决定在本系统中应采用各种路由协议的小型单位。这个网络单位可以是一个简单的网络也可以是一个由一个或多个普通的网络管理员来控制的网络群体,它是一个单独的可管理的网络单元(例如一所大学,一个企业或者一个公司个体)。一个自治系统有时也被称为是一个路由选择域(routing domain)。一个自治系统将会分配一个全局的唯一的16位号码,有时我们把这个号码叫做自治系统号(ASN)。

 

 

 

 

 

 

 

 

1.画出实验所需的网络拓扑图。

――截图(网络拓扑图1个) 

 

 

 

2.为设备接口配置IP地址,并测试网络连通性。

――截图(直接交付和间接交付分别测试2个图)

 

PC的ip设置

PC

ip

子网掩码

默认网关

PC1

100.1.1.10

255.0.0.0

100.1.1.1

PC2

120.1.1.20

255.0.0.0

120.1.1.1

PC3

140.1.1.40

255.255.0.0

140.1.1.1

PC4

160.1.1.60

255.255.0.0

160.1.1.1

 

路由器各接口ip设置

路由器

fastEthernet 0/0

fastEthernet 0/1

Ethernet 1/0

R1

100.1.1.1

110.1.1.1

 

R2

120.1.1.1

110.1.1.2

130.1.1.1

R3

140.1.1.1

130.1.1.2

150.1.1.1

R4

160.1.1.1

150.1.1.2

 

 

下面给出PC4的ip设置结果:

IP地址配置:

 

接口IP地址:

 

R4接口fastEthernet 0/0的ip设置具体代码:

Router>enable

Router#configure terminal

Router(config)#interface fastEthernet 0/0

Router(config-if)#ip address 160.1.1.1 255.255.0.0

Router(config-if)#no shutdown

 

 

 

测试:

直接交互:

PC1 ping R1 连通

 

PC3 ping R3 连通

 

间接交互:

PC1 ping PC2 不通

  

PC3 ping PC4 不通

 

直连网段,要求处在相同的网段内—网络号相同。

路由器的不同端口要求处在不同的网段内,路由器是异构网络互联的设备。

结论:没有路由,无法实现跨网段的通信,只能直接交付,不能间接交付。

 

3.进行路由器基础配置

――截图(每项1个图)

①修改名字:

Router>enable

Router#configure terminal

Router(config)#hostname R1

 

②设置进入特权模式的密码(hi)

R1(config)#enable password hi

 

③设置进入用户模式的密码(123)

R1(config)#line console 0

R1(config-line)#login

R1(config-line)#password 123

 

 

4.在不同的路由器上,设置协议RIP,并测试网络连通性。

――截图(测试2个图、查看路由表1个图)

动态路由协议RIP的格式:(config)# router rip

                        (config-router)# network 直连网段

R1设置协议RIP:

(config)# router rip

(config-router)# network 100.0.0.0

(config-router)# network 110.0.0.0

 

R2设置协议RIP:

(config)# router rip

(config-router)# network 110.0.0.0

(config-router)# network 120.0.0.0

(config-router)# network 130.1.0.0

R3设置协议RIP:

(config)# router rip

(config-router)# network 130.1.0.0

(config-router)# network 140.1.0.0

(config-router)# network 150.1.0.0 

R4设置协议RIP:

(config)# router rip

(config-router)# network 150.1.0.0

(config-router)# network 160.1.0.0

R1路由表

 

测试:

PC1 ping PC2 连通:

 

PC3 ping PC4 连通:

 

5.测试:全网贯通么?结论:网络贯通。

――截图(测试至少2个图、查看R1/R2/R3/R4的路由表1个图)

PC1 ping PC3 连通:

 

PC2 ping PC4 连通:

 

R2路由表:

 

 

 

6.尝试:PC1远程登录到路由器R4。

――截图(在PC1上登录到路由器R4显示的图,并和R4路由器上看到的图对比。)

在R4上设置:

R4(config)#line vty 0

R4(config-line)#password 1234

 

PC1远程登录到R4

 

PC1上显示的R4路由表:

 

R4上显示的R4路由表:

 

PC1远程登录R4看到的图和R4上看到的图相同。

 

1.你的感受。

答:设置动态路由的工作量会明显少于设置静态路由的工作量。

 

2.你的收获。

答:理解路由协议的概念和分类;了解组网技术,搭建远程网络拓扑图;运用路由协议RIP、OSPF和BGP,实现骨干网络的联通。

 

3.你的困难。

答:无。经过上一次实验,对这次实验的操作比较熟悉。

 

4.你的启示。

答:在主机和接口较多的情况下,设置动态路由的效率会明显高于设置静态路由的效率。

posted @ 2022-06-22 16:30  03*333  阅读(13)  评论(0编辑  收藏  举报