HDU3592 差分约束

World Exhibition

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24 Accepted Submission(s): 15
 
Problem Description
Nowadays, many people want to go to Shanghai to visit the World Exhibition. So there are always a lot of people who are standing along a straight line waiting for entering. Assume that there are N (2 <= N <= 1,000) people numbered 1..N who are standing in the same order as they are numbered. It is possible that two or more person line up at exactly the same location in the condition that those visit it in a group.

There is something interesting. Some like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of X (1 <= X <= 10,000) constraints describes which person like each other and the maximum distance by which they may be separated; a subsequent list of Y constraints (1 <= Y <= 10,000) tells which person dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between person 1 and person N that satisfies the distance constraints.
 
Input
First line: An integer T represents the case of test.

The next line: Three space-separated integers: N, X, and Y. 

The next X lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= N. Person A and B must be at most C (1 <= C <= 1,000,000) apart.

The next Y lines: Each line contains three space-separated positive integers: A, B, and C, with 1 <= A < B <= C. Person A and B must be at least C (1 <= C <= 1,000,000) apart.
 
Output
For each line: A single integer. If no line-up is possible, output -1. If person 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between person 1 and N.
 
Sample Input
1
4 2 1
1 3 8
2 4 15
2 3 4
 
Sample Output
19
 
Author
alpc20
 
Source
2010 ACM-ICPC Multi-University Training Contest(15)——Host by NUDT

题意:

给n个人排队,x对人相互喜欢,y对人相互讨厌,输入x行a,b,c表示a和b相互喜欢他们之间的距离要小于等于c,输入y行a,b,c表示a和b相互讨厌他们之间的距离要大于等于c,问是否存在这样的队列,如果不存在输出-1否则输出1到n之间的距离,如果这个距离是任意的则输出-2。、

代码:

//差分约束模板题,存在负环无解,dis[n]=inf说明1和n之间没有限制(没有边相连)可以是任意距离,否则输出dis[n];
//限制条件是两点之间的距离直接b-a<=c,如果是a,b之间有多少个.......要考虑端点b-(a-1)<=c;
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int maxn=1003,inf=0x7fffffff;
int t,x,y,a,b,c;
struct node
{
    int to,next,val;
} edge[20004];//!
int mark[maxn],head[maxn],tot,dis[maxn],n,m,cnt[maxn];
void add(int a,int b,int c)
{
    edge[tot].to=b;
    edge[tot].next=head[a];
    edge[tot].val=c;
    head[a]=tot++;
}
bool spfa(int s)
{
    for(int i=0;i<=n;i++)
        dis[i]=inf;
    memset(mark,0,sizeof(mark));
    memset(cnt,0,sizeof(cnt));
    queue<int>q;
    dis[s]=0;
    mark[s]=1;
    cnt[s]++;
    q.push(s);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        mark[u]=0;
        for(int i=head[u]; i!=-1; i=edge[i].next)
        {
            int v=edge[i].to;
            if(dis[v]>dis[u]+edge[i].val)
            {
                dis[v]=dis[u]+edge[i].val;
                if(!mark[v])
                {
                    cnt[v]++;
                    if(cnt[v]>=n+1) return false;
                    q.push(v);
                    mark[v]=1;
                }
            }
        }
    }
    return true;
}
main()
{
   scanf("%d",&t);
   while(t--){
       memset(head,-1,sizeof(head));
       tot=0;
       scanf("%d%d%d",&n,&x,&y);
       for(int i=0;i<x;i++){
           scanf("%d%d%d",&a,&b,&c);
           add(a,b,c);
       }
       for(int i=0;i<y;i++){
           scanf("%d%d%d",&a,&b,&c);
           add(b,a,-c);
       }
       int tmp=spfa(1);
       if(!tmp) printf("-1\n");
       else if(dis[n]==inf) printf("-2\n");
       else printf("%d\n",dis[n]);
   }
   return 0;
}

 

posted @ 2017-02-04 15:51  luckilzy  阅读(270)  评论(0编辑  收藏  举报