挑战程序设计竞赛-2.1最基础的“穷竭搜索”-Lake Counting

Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 33135   Accepted: 16510

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

代码:

#include <cstdio>


using namespace std;


const int MAX_N = 110;

int n, m,res;
char field[MAX_N][MAX_N];

void dfs(int x, int y) {

    field[x][y] = '.';
    for (int dx = -1; dx <= 1; dx++) {
        int nx = x + dx;
        for (int dy = -1; dy <= 1; dy++) {
            int ny = y + dy;
            if (nx >= 0 && nx < n && ny >= 0 && ny < m && field[nx][ny] == 'W')
                dfs(nx, ny);
        }
    }
        
}

void solve() {

    
    res = 0;
    for (int i = 0; i < n; i++) {
        for (int j = 0; j < m; j++) {
        
            if(field[i][j] == 'W') {
                dfs(i, j);
                res++;
            }
        }
    }

}


int main() {

    scanf("%d %d", &n, &m);

    getchar();  //吃掉换行符
    for (int i = 0; i < n; i++) {
        for (int j = 0; j < m; j++) {  
            scanf("%c", &field[i][j]);
        }
        getchar();
    }

    solve();

    printf("%d\n", res);

    return 0;
}

 



posted @ 2017-03-06 17:48  陈煜弘  阅读(446)  评论(0编辑  收藏  举报