poj1113——凸包

poj1113——凸包

Wall
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 31132   Accepted: 10497

Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall. 

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements. 

The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.

Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle. 

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

Sample Input

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output

1628

Hint

结果四舍五入就可以了
 
题意:用一个篱笆将若干个点围起来,且与每个点的距离必须大于等于L,求需要的最小篱笆长度
思路:凸包周长+以L为直径的圆(多边形内角补角和等于360度),printf输出浮点数时默认四舍五入
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<math.h>

using namespace std;

const int maxn=1000100;
const int INF=(1<<28);
const double EPS=0.000001;
const double Pi=acos(-1.0);

int N,L;
struct Point
{
    double x,y;
    friend double operator*(Point A,Point B)
    {
        return A.x*B.y-A.y*B.x;
    }
    friend Point operator-(Point A,Point B)
    {
        return {A.x-B.x,A.y-B.y};
    }
};
Point vert[maxn];
Point con[maxn];
int top;

double dist(Point A,Point B)
{
    return sqrt(pow(A.x-B.x,2)+pow(A.y-B.y,2));
}

bool cmp(Point A,Point B)
{
    //return (A-vert[0])*(B-vert[0])>EPS;
    double tmp=(A-vert[0])*(B-vert[0]);
    if(tmp>EPS) return true;
    if(fabs(tmp)<EPS) return dist(A,vert[0])>dist(B,vert[0])+EPS;///极角相同时,距离远的在前
    return false;
}

bool cmpYX(Point A,Point B)
{
    if(A.y<B.y-EPS) return true;
    if(A.y==B.y) return A.x<B.x-EPS;
    return false;
}

void graham_scan()
{
    sort(vert,vert+N,cmpYX);
    sort(vert+1,vert+N,cmp);
    top=0;
    con[top++]=vert[0];
    con[top++]=vert[1];
    for(int i=2;i<=N;i++){
        if((con[top-1]-con[top-2])*(vert[i%N]-con[top-1])<-EPS){
            top--;
            con[top++]=vert[i%N];
        }
        else if(fabs((con[top-1]-con[top-2])*(vert[i%N]-con[top-1]))<EPS){///拐向相同时,取距离远的,舍弃距离近的
            if(dist(vert[i%N],con[top-2])>dist(con[top-1],con[top-2])+EPS){
                top--;
                con[top++]=vert[i%N];
            }
        }
        else con[top++]=vert[i%N];
        while(top>=3&&(con[top-2]-con[top-3])*(con[top-1]-con[top-2])<EPS){///这步处理是必要的
            Point tmp=con[top-1];
            top-=2;
            con[top++]=tmp;
        }
    }
}


int main()
{
    while(cin>>N>>L){
        for(int i=0;i<N;i++){
            scanf("%lf%lf",&(vert[i].x),&(vert[i].y));
        }
        graham_scan();
        double ans=2*L*Pi;
        for(int i=0;i<top;i++){
            ans+=dist(con[i],con[(i+1)%top]);
        }
        printf("%.0f\n",ans);
    }
    return 0;
}
View Code

 

posted @ 2015-04-07 19:43  __560  阅读(220)  评论(0编辑  收藏  举报