HDU 2674 N!Again (数论-水题)

N!Again

Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!
 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 

Output
For each case, output N! mod 2009
 

Sample Input
4 5
 

Sample Output
24 120
 

Author
WhereIsHeroFrom
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2672 2668 2673 2669 2671 
 

题目大意:

求N!%2009的最大值,n最大10^9;


解题思路:

我靠,乍一看数据量挺大的,几秒后反应过来,n>=2009后还要计算个毛线。


解题代码:

#include <iostream>
#include <cstdio>
using namespace std;

int n;

int main(){
    while(scanf("%d",&n)!=EOF){
        if(n>=2009) printf("0\n");
        else{
            int ans=1;
            for(int i=2;i<=n;i++){
                ans=(ans*i)%2009;
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}





posted @ 2014-08-01 14:15  炒饭君  阅读(177)  评论(0编辑  收藏  举报