分组背包(每组可选多个)

Description

After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.
There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand. Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice. Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.
 

Input

Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.
 

Output

For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.
 

Sample Input

5 10000 3 1 4 6 2 5 7 3 4 99 1 55 77 2 44 66
 

Sample Output

255
#include<iostream>

#include<string.h>

#define INF 999999999;

using namespace std;

int f[105][10005];//f[i][j]表示的是取到第 i 个品牌,花费为 j 的时候的最优值,

int brand[105];

int price[105];

int value[105];



int main()

{int i,j,k;

    int N,M,K;

    while(cin>>N>>M>>K)

    {

        for(i=1;i<=N;i++)

            cin>>brand[i]>>price[i]>>value[i];

       for(i=0;i<100005;i++)
         f[0][i]=0;


        for(i=1;i<=K;i++)

            for(j=0;j<=M;j++)

                f[i][j]=-INF;  //实现每组至少放一个

        for(i=1;i<=K;i++)//先固定一种牌子的商品,一种牌子的商品看做一组
            for(k=1;k<=N;k++)//一共N个产品
               for(j=M;j>=0;j--)
                      //每组物品可以放多个,如果每组物品只能放一个的话,2、3循环对调

                    if(brand[k]==i&&j>=price[k])//从每组商品中寻找若干个能获得最大价值的商品



                        f[i][j]=max(f[i][j],max(f[i][j-price[k]]+value[k],f[i-1][j-price[k]]+value[k]));//跟 i-1 比较,保证至少每组选一个

if(f[K][M]<0) cout<<"Impossible"<<endl;

       else cout<<f[K][M]<<endl;

    }

      return 0;

}

 

posted @ 2013-10-08 20:09  蓝色记忆2013  阅读(281)  评论(0编辑  收藏  举报