1103 Integer Factorization

The KP factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the KP factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (400), K (N) and P (1<P7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P
 

where n[i] (i = 1, ..., K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122+42+22+22+12, or 112+62+22+22+22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1,a2,,aK } is said to be larger than { b1,b2,,bK } if there exists 1LK such that ai=bi for i<L and aL>bL.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2
 

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
 

Sample Input 2:

169 167 3
 

Sample Output 2:

Impossible


#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<vector>                  //用vector方便更新 
using namespace std;


int seq[500];
int num;
int p;
int k;
int i=0;
vector<int> temp;
vector<int>result;
int maxsum=-1;
void find(int index,int nowk,int sum,int seqsum)
{

    if(sum==num&&nowk==k)
    {
        if(seqsum>maxsum)
        {
            maxsum=seqsum;
            result=temp;
        }
        return; 
     } 
    
    if(sum>num||nowk>k||index<1) 
    return;
    temp.push_back(index);
    find(index,nowk+1,sum+seq[index],seqsum+index);
    temp.pop_back();
    find(index-1,nowk,sum,seqsum);
    
    
}
int main()
{
    
    scanf("%d",&num);
    scanf("%d",&k);
    scanf("%d",&p);
    
    while(pow(i,p)<=num)
    {
        seq[i]=pow(i,p);
        i++;
    }
    find(i-1,0,0,0);
    int tempk=0;
    if(maxsum==-1)
    {
        printf("Impossible");
    }
    else
    {
        while(result.size()!=tempk)
    {
        if(tempk==0)
        {
            printf("%d = %d^%d",num,result[tempk],p);
            tempk++;
        }
        else
        {
            printf(" + %d^%d",result[tempk],p);
            tempk++;    
        }
    
    }
    
    }

 } 

 

 
posted @ 2022-11-19 02:07  zzzlight  阅读(16)  评论(0编辑  收藏  举报