A - Bi-shoe and Phi-shoe (素数筛)

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than nwhich are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

//Full of love and hope for life

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <queue>
#define inf 0x3f3f3f3f
//https://paste.ubuntu.com/

using namespace std;

typedef long long ll;
const ll maxn=1e6+100;

ll prime[maxn];

void init(){
    prime[1]=1;
    for(ll i=2;i<=1000010;i++){
        if(prime[i]==0){
            for(ll j=i+i;j<=1000010;j+=i){
                prime[j]=1;
            }
        }
    }
}

int main(){
    ll a,b,x,sum,k=0;
    cin >> a;
    memset(prime,0,sizeof(prime));
    init();
    while(a--){
            k++;
            sum=0;
        cin >> b;
        for(ll i=1;i<=b;i++){
            cin >> x;
            for(ll j=x+1;j<=1000010;j++){
                if(prime[j]==0){
                    sum+=j;
                    break;
                }
            }
        }
        cout << "Case " << k << ": ";
        cout << sum << " Xukha" << endl;;
    }
    return 0;
}

 

posted @ 2019-08-10 14:50  soiderKB  阅读(150)  评论(0编辑  收藏  举报