hdu 3549:Flow Problem(最大流)

http://acm.hdu.edu.cn/showproblem.php?pid=3549

Problem Description

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.

 

 

Input

The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

 

 

Output

For each test cases, you should output the maximum flow from source 1 to sink N.

Sample Input

2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1

 

Sample Output

Case 1: 1
Case 2: 2

题意分析:

求1到n的最大流。

FF算法:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <vector>
using namespace std;
#define N 20
int book[N];
int n, m, inf=0x3f3f3f;
struct edge {
	int v; 
	int w;
	int rev;
};
vector<edge>e[N];
int dfs(int s, int t, int f)
{
	if (s==t)
		return f;
	book[s] = 1;
	int u, v, d;
	for (v = 0; v < e[s].size(); v++)
	{
		edge &G = e[s][v];
		if (G.w && !book[G.v])
		{
			d = dfs(G.v,t, min(f, G.w));
			if (d > 0)
			{
				G.w -= d;
				e[G.v][G.rev].w += d;
				return d;
			}
				
		}
	}
	return 0;
}
int FF(int s, int t)
{
	int d, sum = 0;
	while (1)
	{
		memset(book, 0, sizeof(book));
		d = dfs(s, t, inf);
		if (d == 0)
			break;
		sum += d;
	}
	return sum;
}
int main()
{
	int t = 0, T, u, v, w, i;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d%d", &n, &m);
		for (i = 1; i <= n; i++)
			e[i].clear();
		while (m--)
		{
			scanf("%d%d%d", &u, &v, &w);
			e[u].push_back(edge{v, w, e[v].size()});
			e[v].push_back(edge{u, 0, e[u].size()-1});
		}
		printf("Case %d: %d\n", ++t, FF(1, n));
	}
	return 0;
}

EK算法:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
using namespace std;
#define N 20
int e[20][20], pre[N], flow[N];
int n, m, inf=0x3f3f3f;
queue<int>q;
int bfs(int s, int t)
{
	int u, v;
	while (!q.empty())
		q.pop();
	memset(pre, -1, sizeof(pre));
	flow[s] = inf;
	q.push(s);
	while (!q.empty())
	{
		u = q.front();
		q.pop();
		if (u == t)
			break;
		for (v=1; v<=n; v++)
			if (pre[v] == -1 && v != s && e[u][v])
			{
				pre[v] = u;
				q.push(v);
				flow[v] = min(flow[u], e[u][v]);
			}
	}
	if (pre[t] == -1)
		return -1;
	return flow[t];
}
int EK(int s, int t)
{
	int d, p, sum=0;
	while (1)
	{
		d = bfs(s, t);
		if (d == -1)
			break;
		p = t;
		while (p != s)
		{
			e[pre[p]][p] -= d;
			e[p][pre[p]] += d;
			p = pre[p];
		}
		sum += d;
	}
	return sum;
}
int main()
{
	int t = 0, T, u, v, w;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d%d", &n, &m);
		memset(e, 0, sizeof(e));
		while (m--)
		{
			scanf("%d%d%d", &u, &v, &w);
			e[u][v] += w;
		}
		printf("Case %d: %d\n", ++t, EK(1, n));
	}
	return 0;
}

 

posted @ 2019-07-17 14:38  宿星  阅读(90)  评论(0编辑  收藏  举报