1001 Sum Problem [ACM刷题]

这一段时间一直都在刷OJ,这里建一个博客合集,用以记录和分享算法学习的进程。
 
Problem Description
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1
100
Sample Output
1
5050
CODE
#include <iostream>
using namespace std;
int main()
{
    int n;
    while(cin >> n)
    {
        int sum = 0;
        while(n)
        {
            sum += n;
            n--;
        }
        cout << sum << endl;
        cout << endl;
    }
    return 0;
}

 

posted @ 2016-03-11 17:17  贫贫贫贫僧  阅读(136)  评论(0编辑  收藏  举报