【HDU 5934】Bomb(强连通缩点)

Problem Description

There are N bombs needing exploding.
Each bomb has three attributes: exploding radius ri, position (xi,yi) and lighting-cost ci which means you need to pay ci cost making it explode.
If a un-lighting bomb is in or on the border the exploding area of another exploding one, the un-lighting bomb also will explode.
Now you know the attributes of all bombs, please use the minimum cost to explode all bombs.

Input

First line contains an integer T, which indicates the number of test cases.
Every test case begins with an integers N, which indicates the numbers of bombs.
In the following N lines, the ith line contains four intergers xi, yi, ri and ci, indicating the coordinate of ith bomb is (xi,yi), exploding radius is ri and lighting-cost is ci.
Limits

  • 1≤T≤20
  • 1≤N≤1000
  • −108≤xi,yi,ri≤108
  • 1≤ci≤104

Output

For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the minimum cost.

Sample Input

1
5
0 0 1 5
1 1 1 6
0 1 1 7
3 0 2 10
5 0 1 4

Sample Output

Case #1: 15

Source

2016年中国大学生程序设计竞赛(杭州)

题解

把一个炸弹可以炸到另一个看作一条有向边,然后再进行强连通缩点。对于新生成的图,我们只需引燃所有没有边指向的点,即可炸掉所有炸弹。

#include <map>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>

using namespace std;
const int N = 1005;
	// N为最大点数
const int M = 1000005;
	// M为最大边数

struct Edge{
    int from, to, nex;
    bool sign;//是否为桥
}edge[M<<1];
int head[N], edgenum;
void add(int u, int v){//边的起点和终点
    Edge E={u, v, head[u], false};
    edge[edgenum] = E;
    head[u] = edgenum++;
}

int DFN[N], Low[N], Stack[N], top, Time; //Low[u]是点集{u点及以u点为根的子树} 中(所有反向弧)能指向的(离根最近的祖先v) 的DFN[v]值(即v点时间戳)
int taj;//连通分支标号,从1开始
int Belong[N];//Belong[i] 表示i点属于的连通分支
bool Instack[N];
vector<int> bcc[N]; //标号从1开始

void tarjan(int u ,int fa){
    DFN[u] = Low[u] = ++ Time ;
    Stack[top ++ ] = u ;
    Instack[u] = 1 ;

    for (int i = head[u] ; ~i ; i = edge[i].nex ){
        int v = edge[i].to ;
        if(DFN[v] == -1)
        {
            tarjan(v , u) ;
            Low[u] = min(Low[u] ,Low[v]) ;
            if(DFN[u] < Low[v])
            {
                edge[i].sign = 1;//为割桥
            }
        }
        else if(Instack[v]) Low[u] = min(Low[u] ,DFN[v]) ;
    }
    if(Low[u] == DFN[u]){
        int now;
        taj ++ ; bcc[taj].clear();
        do{
            now = Stack[-- top] ;
            Instack[now] = 0 ;
            Belong [now] = taj ;
            bcc[taj].push_back(now);
        }while(now != u) ;
    }
}

void tarjan_init(int all){
    memset(DFN, -1, sizeof(DFN));
    memset(Instack, 0, sizeof(Instack));
    top = Time = taj = 0;
    for(int i=1;i<=all;i++)if(DFN[i]==-1 )tarjan(i, i); //注意开始点标!!!
}
vector<int>G[N];
int du[N];
void suodian(){
    memset(du, 0, sizeof(du));
    for(int i = 1; i <= taj; i++)G[i].clear();
    for(int i = 0; i < edgenum; i++){
        int u = Belong[edge[i].from], v = Belong[edge[i].to];
        if(u!=v)G[u].push_back(v), du[v]++;
    }
}
int sz;

void init(){memset(head, -1, sizeof(head));sz=0; edgenum=0;}

int cost[N];
map<int,map<int,int> > vis;
int find(int x, int y, int c) {
    if(!vis[x][y]){vis[x][y]=++sz;cost[sz]=c;}
    return vis[x][y];
}

struct node
{
    int x, y, r, c;

    node(int tx, int ty, int tr, int tc)
    {
        x = tx;
        y = ty;
        r = tr;
        c = tc;
    }
    node() {}
};

node a[N];
int ans[N];

bool isTouch(int i, int j)
{
    long long dx = a[i].x - a[j].x;
    long long dy = a[i].y - a[j].y;
    long long dr = a[i].r;
    return dx * dx + dy * dy <= dr * dr;
}


int main()
{
    int T, ca = 1;
    cin>>T;
    int n, x, y, r, c;
    while (T--)
    {
        cin>>n;
        vis.clear();
        init();
        for (int i = 0; i < n; i++)
        {
            cin>>x>>y>>r>>c;
            a[i] = node(x, y, r, c);
        }
        int id1, id2;
        for (int i = 0; i < n; i++)
        {
            id1 = find(a[i].x, a[i].y, a[i].c);
            for (int j = 0; j < n; j++)
            {
                if (i == j)
                    continue;
                if (!isTouch(i, j))
                    continue;
                id2 = find(a[j].x, a[j].y, a[j].c);
                add(id1, id2);
            }
        }
        tarjan_init(n);
        suodian();
        int cnt = 0;
        for (int i = 1; i <= taj; i++)
        {
            if (du[i] == 0)
            {
                ans[cnt++] = i;
            }
        }
        int sum = 0, tmp = 0;
        for (int i = 0; i < cnt; i++)
        {
            for (int j = 0; j < bcc[ans[i]].size(); j++)
            {
                if (j == 0)
                    tmp = cost[bcc[ans[i]][j]];
                else
                    tmp = min(tmp, cost[bcc[ans[i]][j]]);
            }
            sum += tmp;
        }
        cout<<"Case #" << (ca++) << ": " << sum<<endl;
    }
    return 0;
}
posted @ 2017-07-28 16:15  江南何采莲  阅读(270)  评论(0编辑  收藏  举报