Sweety

Practice makes perfect

导航

棋盘问题

Posted on 2016-05-06 09:22  蓝空  阅读(105)  评论(0编辑  收藏  举报

A - 棋盘问题
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

在一个给定形状的棋盘(形状可能是不规则的)上面摆放棋子,棋子没有区别。要求摆放时任意的两个棋子不能放在棋盘中的同一行或者同一列,请编程求解对于给定形状和大小的棋盘,摆放k个棋子的所有可行的摆放方案C。

Input

输入含有多组测试数据。 
每组数据的第一行是两个正整数,n k,用一个空格隔开,表示了将在一个n*n的矩阵内描述棋盘,以及摆放棋子的数目。 n <= 8 , k <= n 
当为-1 -1时表示输入结束。 
随后的n行描述了棋盘的形状:每行有n个字符,其中 # 表示棋盘区域, . 表示空白区域(数据保证不出现多余的空白行或者空白列)。 

Output

对于每一组数据,给出一行输出,输出摆放的方案数目C (数据保证C<2^31)。

Sample Input

2 1
#.
.#
4 4
...#
..#.
.#..
#...
-1 -1

Sample Output

2
1

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#include<string>
#include<map>
#include<set>
#include<ctime>
#define eps 1e-6
#define LL long long
#define pii pair<string, int>
#define rd(x) scanf("%d",&x)
#define rd2(x,y) scanf("%d%d",&x,&y)
using namespace std;
char mmap[10][10];
bool vis[10];
int n,k;
int dfs(int row,int coun){
   //cout<<row<<' '<<coun<<"**********"<<endl;
   int sum=0;
   if(coun == k) return 1;
   if(row < n){
       for(int i=0;i<n;i++){
         if(vis[i]==false&&mmap[row][i] == '#'){
           vis[i] = true;
           sum+=dfs(row+1,coun+1);
           vis[i] = false;
         }
       }
       sum+=dfs(row+1,coun);
   }
   return sum;
}
int main (){
  while(~rd2(n,k)&&n!=-1&&k!=-1){
        memset(vis,0,sizeof(vis));
        for(int i=0;i<n;i++){
            scanf("%s",mmap[i]);
        }
        printf("%d\n",dfs(0,0));
  }
return 0;
}