PAT 1147 Heaps

https://pintia.cn/problem-sets/994805342720868352/problems/994805342821531648

 

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

代码:

#include <bits/stdc++.h>
using namespace std;

int N, M;
vector<int> level;

void postorder(int st) {
    if(st >= N) return ;
    postorder(st * 2 + 1);
    postorder(st * 2 + 2);
    printf("%d%s", level[st], st == 0 ? "\n" : " ");
}

int main() {
    scanf("%d%d", &M, &N);
    level.resize(N);
    while(M --) {
        for(int i = 0; i < N; i ++)
            scanf("%d", &level[i]);

        int flag;
        if(level[0] > level[1]) flag = 1; // max
        else if(level[0] < level[1]) flag = -1; // min

        for(int i = 0; i <= (N - 1) / 2; i ++) {
            int l = i * 2 + 1, r = i * 2 + 2;
            if(flag == 1 && (level[i] < level[l] || r < N && level[r] > level[i])) flag = 0;
            if(flag == -1 && (level[i] > level[l] || r < N && level[r] < level[i])) flag = 0;
        }

        if(flag == 0) printf("Not Heap\n");
        else if(flag == 1) printf("Max Heap\n");
        else if(flag == -1) printf("Min Heap\n");

        postorder(0);
    }
    return 0;
}

  堆最后一层不满的话是都靠左排的 头是 level[0] 先判断 level[0] 和 level[1] 的大小关系初步假设是最大堆还是最小堆 然后进行判断 0 到 (N - 1) / 2 的点都是有孩子节点的 如果父亲节点是 index 那么左儿子是 index * 2 + 1 右儿子是 index * 2 + 2 

FHFHFH

posted @ 2019-01-29 20:27  丧心病狂工科女  阅读(100)  评论(0编辑  收藏  举报