霧首

总会实现的

  博客园  :: 首页  :: 新随笔  :: 联系 :: 订阅 订阅  :: 管理

WebService的小问题

WebService 出现因 URL 意外地以“/*****”结束,请求格式无法识别

原因:

与 .NET 连接的 Web 服务支持 HTTP GET、HTTP POST 及 SOAP 通讯协议。根据预设,在 .NET Framework 1.0 中,这三种通讯协议均设定为启用。在 .NET Framework 1.1 中,HTTP GET 及 HTTP POST 是预设为停用。这是基于安全性的考虑。

当 Web 服务升级至 .NET Framework 1.1 时,使用 HTTP GET 或 HTTP POST 来叫用 Web 服务的应用程序就会失败。这些应用程序会收到
System.Net.WebException
错误讯息,表示无法辨识要求的格式。

解决的方法:

所以只要在Webservice中将默认关闭的HTTP GET、HTTP POST 打开就可以解决上面的问题,要在webservice的web.config文件中的 <system.web> 节点下加入

 

<webServices>
    <protocols>
        <add name= "HttpPost"/>
        <add name= "HttpGet"/>
    </protocols>
</webServices>

 

WebService找到多个终结点配置

解决的方法:

打开项目的app.config里的节点是不是有多个节点,是的话就将其他的节点删除,保留一个节点

  

 

posted on 2013-04-24 21:06  凯的博客  阅读(177)  评论(0)    收藏  举报