zoj1089 Lotto(组合)

Lotto

Time Limit: 2 Seconds      Memory Limit: 65536 KB

In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k>6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34].

Your job is to write a program that reads in the number kand the set S and then prints all possible games choosing numbers only from S.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k.

Output Specification

For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case.

Sample Input

7 1 2 3 4 5 6 7
8 1 2 3 5 8 13 21 34
0

Sample Output

1 2 3 4 5 6
1 2 3 4 5 7
1 2 3 4 6 7
1 2 3 5 6 7
1 2 4 5 6 7
1 3 4 5 6 7
2 3 4 5 6 7

1 2 3 5 8 13
1 2 3 5 8 21
1 2 3 5 8 34
1 2 3 5 13 21
1 2 3 5 13 34
1 2 3 5 21 34
1 2 3 8 13 21
1 2 3 8 13 34
1 2 3 8 21 34
1 2 3 13 21 34
1 2 5 8 13 21
1 2 5 8 13 34
1 2 5 8 21 34
1 2 5 13 21 34
1 2 8 13 21 34
1 3 5 8 13 21
1 3 5 8 13 34
1 3 5 8 21 34
1 3 5 13 21 34
1 3 8 13 21 34
1 5 8 13 21 34
2 3 5 8 13 21
2 3 5 8 13 34
2 3 5 8 21 34
2 3 5 13 21 34
2 3 8 13 21 34
2 5 8 13 21 34
3 5 8 13 21 34

分析:从 n 个元素选择 6 个元素的组合,其实这个题目有个不好处理的就是最后一个案例不能有换行。把案例看成以文件读入读出,第一个输出不换行,第二个输入再换行。
方法一:6层循环法: 这种方法针对性比较强,所以如果在比赛中选择这方法,比较合适,清晰明了。
View Code
#include<iostream>
#include<cstdio>
using namespace std;

int A[15],ans[10];

void output()
{
    int i;
    for(i=1;i<=6;i++) cout<<ans[i]<<" ";
    cout<<endl;
}

int main()
{
    int i,n;
    int flag=false;
    while(cin>>n&&n)
    {
        if(flag)  cout<<endl;
        for(i=1;i<=n;i++) cin>>A[i];
        int a,b,c,d,e,f;
        for(a=1;a<=n-5;a++)
        {
            ans[1]=A[a];
            for(b=a+1;b<=n-4;b++)
            {
                ans[2]=A[b];
                for(c=b+1;c<=n-3;c++)
                {
                    ans[3]=A[c];
                    for(d=c+1;d<=n-2;d++)
                    {
                        ans[4]=A[d];
                        for(e=d+1;e<=n-1;e++)
                        {
                            ans[5]=A[e];
                            for(f=e+1;f<=n;f++)
                            {
                                ans[6]=A[f];
                            //    output();
                                printf("%d %d %d %d %d %d\n",A[a],A[b],A[c],A[d],A[e],A[f]);
                                flag=true;
                            }
                        }
                    }
                }
            }
        }
    }
    return 0;
}


方法二:递归实现从 n 个元素中选择 m 个元素,常规法.
View Code
#include<iostream>
#include<algorithm>
using namespace std;
int a[15],ans[7],n,m=6;
bool visited[15],flag;

void output()
{
    int i;
    for(i=1;i<m;i++) cout<<ans[i]<<" ";
    cout<<ans[i];
    cout<<endl;
}

void work(int i,int k)
{
    int j;
    if(i==m+1)
    {
        output();return ;
    }
    for(j=k;j<=n;j++)
    {
        if(!visited[j])
        {
            ans[i]=a[j];k=j;
            visited[j]=true;            
            work(i+1,k);
            visited[j]=false;
        }
    }
}

int main()
{
    int test=0;
    while(1)
    {
        cin>>n;
        test++;
        if(n==0)
        {
            break;
        }
        if(test>1)cout<<endl;
        int i;
        flag=false;
        for(i=1;i<=n;i++)
        {
            cin>>a[i];
            visited[i]=false;
        }
        work(1,1);
    }
    return 0;
}

 

posted @ 2012-04-10 21:10  mtry  阅读(643)  评论(0编辑  收藏  举报