hdu-1286 找新朋友(欧拉函数,水题)

题目链接:

找新朋友

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10120    Accepted Submission(s): 5344


Problem Description
新年快到了,“猪头帮协会”准备搞一个聚会,已经知道现有会员N人,把会员从1到N编号,其中会长的号码是N号,凡是和会长是老朋友的,那么该会员的号码肯定和N有大于1的公约数,否则都是新朋友,现在会长想知道究竟有几个新朋友?请你编程序帮会长计算出来。
 

 

Input
第一行是测试数据的组数CN(Case number,1<CN<10000),接着有CN行正整数N(1<n<32768),表示会员人数。
 

 

Output
对于每一个N,输出一行新朋友的人数,这样共有CN行输出。
 

 

Sample Input
2
25608
24027
 

 

Sample Output
7680
16016
AC代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int N=1e5+3;
int phi[N];
int get_phi()
{
    for(int i=2;i<N;i++)
    {
        if(!phi[i])
        {
            for(int j=i;j<N;j+=i)
            {
                if(!phi[j])phi[j]=j;
                phi[j]=phi[j]/i*(i-1);
            }
        }
    }
}
int main()
{
    get_phi();
    int a,b,n;
    scanf("%d",&n);
    while(n--)
    {
        int x;
        scanf("%d",&x);
        cout<<phi[x]<<"\n";
    }
    return 0;
}

 

posted @ 2016-03-13 23:38  LittlePointer  阅读(196)  评论(0编辑  收藏  举报