Euclid's Game

Starts with two unequal positive numbers (M,N and M>N) on the board. Two players move in turn. On each move, a player has to write on the board a positive number equal to the difference of two numbers already on the board; this number must be new, i.e., different from all the numbers already on the board. The player who cannot move loses the game. Should you choose to move first or second in this game?

According to the above rules, there are two players play tihs game. Assumptions A write a number on the board at first, then B write it.

Your task is write a program to judge the winner is A or B.

Input

Two unequal positive numbers M and N , M>N (M<1000000)

Output

A or B

Sample Input

3 1

Sample Output

A



#include<stdio.h>
int gcd(long a,long b)
{
return b==0?a:gcd(b,a%b);
}
void main()
{
long m,n;
scanf("%d %d",&m,&n);
m=m/gcd(m,n);
if(m%2)printf("A\n");
else printf("B\n");
}

posted @ 2013-07-20 12:04  失眠的娃儿  阅读(279)  评论(0编辑  收藏  举报