POJ2488——DFS——A Knight's Journey

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany
大意:一个骑士从原点出发,只能走马字型路线, 要求遍历所有路径的字典序排序(就是先A再B再C),用DFS思想遍历每一种状态,如果最后步数等于图的大小那么就直接输出,难在字典序排序(虽然还不知道为什么这样写dir这个数组- -||),用visit记录已经经过的点,最后如果DFS失败那么visit要重新变成0
#include<cstdio>
#include<cstring>
using namespace std;
const int inf = 27;
int visit[inf][inf];
int dir[8][2] = {{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
int flag ,p, q,ans;
struct edge{
    char s;
    int num;
}a[inf*inf];
void dfs(int x,int y,int step)
{
    if(flag == 0 ) return  ;
    if(visit[x][y]) return ;
    visit[x][y] = 1;
    if(step == ans){
            flag = 0;
            for(int i = 1; i <= ans;i++)
                printf("%c%d",a[i].s,a[i].num);
                printf("\n");
                return ;

    }
    for(int i = 0; i < 8 ; i++){
        int x1 = x + dir[i][0];
        int y1 = y +dir[i][1];
        if( x1 < 1||y1 < 1||x1 >p||y1 > q||visit[x1][y1] == 1)
            continue;
        a[step+1].s = 'A' + y1 - 1;
        a[step+1].num =  x1;
        dfs(x1,y1,step+1);
        visit[x1][y1] = 0;
    }
}



int main()
{
int T,count = 1;
scanf("%d",&T);
while(T--){
    memset(visit,0,sizeof(visit));
     flag = 1;
     a[1].s = 'A',a[1].num = 1;
    scanf("%d%d",&p,&q);
    ans = p*q;
    printf("Scenario #%d:\n",count++);
    dfs(1,1,1);
    if(flag == 1)
    printf("impossible\n");
    if(T!=0)
    printf("\n");
}
return 0;
}
View Code

 

posted @ 2015-03-13 21:13  Painting、时光  阅读(154)  评论(0编辑  收藏  举报